NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
CRITICAL severity

CVE-2024-27922 — @tomphttp/bare-server-node

CRITICAL

CVE-2024-27922 is a critical-severity (CVSS 9.8) CWE-444 vulnerability in @tomphttp/bare-server-node. A fix is available for @tomphttp/bare-server-node — see the affected versions and patch details below.

HTTP Handling Vulnerability in the Bare server

Also known asGHSA-86fc-f9gr-v533
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-27922.

EPSS Exploitation Probability

via FIRST.org ↗
0.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs57th percentile — riskier than 57% of all scored CVEsHighest risk
0.04%0.47%0.90%1.32%0.5%0.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

7other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
@tomphttp/bare-server-nodenpm
1Kdownloads / week

Description

Impact

This vulnerability relates to insecure handling of HTTP requests by the @tomphttp/bare-server-node package. This flaw potentially exposes the users of the package to manipulation of their web traffic. The impact may vary depending on the specific usage of the package but it can potentially affect any system where this package is in use.

Patches

Yes, the problem has been patched. We advise all users to upgrade to version @tomphttp/[email protected] as soon as possible.

Workarounds

Given the nature of the vulnerability, the most effective solution is to upgrade to the patched version of the package. Specific workaround strategies will be disclosed later due to security considerations.

References

Further information about this vulnerability will be provided at a later date to provide users with an opportunity to upgrade to a patched version and to prevent potential exploitation of the vulnerability. Users are advised to follow the repository announcements and updates.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npm@tomphttp/bare-server-nodeall versions2.0.2npm install @tomphttp/bare-server-node@2.0.2

Affected Products

1 product · 1 configurations
Application
tomp bare servertomphttp
< 2.0.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @tomphttp/bare-server-node, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update @tomphttp/bare-server-node to 2.0.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-27922 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

### Impact This vulnerability relates to insecure handling of HTTP requests by the @tomphttp/bare-server-node package. This flaw potentially exposes the users of the package to manipulation of their web traffic. The impact may vary depending on the specific usage of the package but it can potentially affect any system where this package is in use. ### Patches Yes, the problem has been patched. We advise all users to upgrade to version @tomphttp/[email protected] as soon as possible. ### Workarounds Given the nature of the vulnerability, the most effective solution is to upgrade to the p
O3 Security · Impact-Aware SCA

Is CVE-2024-27922 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2024-27922: @tomphttp/bare-server — Fixed in 2.0.2