CVE-2024-26483 — cms
HIGHCVE-2024-26483 is a high-severity (CVSS 8.8) Code Injection vulnerability in getkirby/cms. A fix is available for getkirby/cms — see the affected versions and patch details below.
Kirby vulnerable to unrestricted file upload of user avatar images
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
- A successful exploit gives an attacker total control of the affected component, not partial access.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-26483.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
getkirby/cms🐘getkirby/cms🐘getkirby/cms🐘getkirby/cms🐘getkirby/cms🐘getkirby/cmsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
TL;DR
This vulnerability affects all Kirby sites that might have potential attackers in the group of authenticated Panel users.
The attack requires user interaction by another user or visitor and cannot be automated.
Introduction
Unrestricted upload of files with a dangerous type is a type of vulnerability that allows to circumvent expectations and protections in the server setup or backend code. Uploaded files are not checked for their compliance with the intended purpose of the upload target, which can introduce secondary attack vectors.
While the vulnerability described here does not allow critical attacks like remote code execution (RCE), it can still be abused to upload unexpected file types that could for example make it possible to perform cross-site scripting (XSS) attacks.
Impact
Users with Panel access can upload a user avatar in their own account view. This avatar is intended to be an image, however the file type or file extension was not validated on the backend. This effectively allowed to upload many types of files that would then be stored with the filename profile and the provided file extension.
While the upload is protected against dangerous file types such as HTML files or executable PHP files, this could be abused to upload unexpected files such as PDFs that would then be available via a direct link. These links could be shared to other users.
Patches
The problem has been patched in Kirby 3.6.6.5, Kirby 3.7.5.4, Kirby 3.8.4.3, Kirby 3.9.8.1, Kirby 3.10.0.1, and Kirby 4.1.1. Please update to one of these or a later version to fix the vulnerability.
In all of the mentioned releases, we have added validations that prevent any files that don't have an image file extension or MIME type from being uploaded as a user avatar.
Credits
Thanks to Natwara Archeepsamooth (@PlyNatwara) for responsibly reporting the identified issue.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | getkirby/cms | all versions | 3.6.6.5composer require getkirby/cms:^3.6.6.5 |
| 🐘Packagist | getkirby/cms | ≥ 3.7.0&&< 3.7.5.4 | 3.7.5.4composer require getkirby/cms:^3.7.5.4 |
| 🐘Packagist | getkirby/cms | ≥ 3.8.0&&< 3.8.4.3 | 3.8.4.3composer require getkirby/cms:^3.8.4.3 |
| 🐘Packagist | getkirby/cms | ≥ 3.9.0&&< 3.9.8.1 | 3.9.8.1composer require getkirby/cms:^3.9.8.1 |
| 🐘Packagist | getkirby/cms | ≥ 3.10.0&&< 3.10.0.1 | 3.10.0.1composer require getkirby/cms:^3.10.0.1 |
| 🐘Packagist | getkirby/cms | ≥ 4.0.0&&< 4.1.1 | 4.1.1composer require getkirby/cms:^4.1.1 |
Affected Products
kirbygetkirbyDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for getkirby/cms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update getkirby/cms to 3.6.6.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-26483 is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
Frequently Asked Questions
Is CVE-2024-26483 in your dependencies?
Find it across Packagist, including transitive dependencies.