CVE-2024-26481 — cms
MEDIUMCVE-2024-26481 is a medium-severity (CVSS 4.7) Cross-site Scripting (XSS) vulnerability in getkirby/cms. A fix is available for getkirby/cms — see the affected versions and patch details below.
Kirby vulnerable to self cross-site scripting (self-XSS) in the URL field
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-26481.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
getkirby/cms🐘getkirby/cms🐘getkirby/cms🐘getkirby/cms🐘getkirby/cms🐘getkirby/cmsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
TL;DR
This vulnerability affects Kirby sites that use the URL field in any blueprint.
A successful attack commonly requires knowledge of the content structure by the attacker as well as social engineering of a user with access to the Panel. The attack cannot be automated.
The vulnerability is also limited to self-XSS and cannot directly affect other users or visitors of the site.
Introduction
Cross-site scripting (XSS) is a type of vulnerability that allows to execute any kind of JavaScript code inside the Panel session of the same or other users. In the Panel, a harmful script can for example trigger requests to Kirby's API with the permissions of the victim.
Self cross-site scripting (self-XSS, also called reflected XSS) typically involves a user inadvertently executing malicious code within their own context, often through social engineering techniques. This can occur when a user is tricked into pasting and executing malicious JavaScript code into the browser's developer console, address bar or form fields.
Such vulnerabilities are critical as they allow attackers to gain access to the system or to escalate their privileges if they get access to the Panel session of an admin user. Depending on your site, other JavaScript-powered attacks are possible.
Impact
The URL field allows users to open the entered link in a new tab by clicking the link icon inside the field. This can be used to quickly verify whether the entered URL is functional and correct.
In affected versions, Kirby copied the entered URL into the link target of that link button without validating or sanitizing the link. This could be abused by attackers with a javascript: URL that would then be executed in the user's context when the link button was clicked with <kbd>Ctrl+Click</kbd>/<kbd>Cmd+Click</kbd>.
Patches
The problem has been patched in Kirby 3.6.6.5, Kirby 3.7.5.4, Kirby 3.8.4.3, Kirby 3.9.8.1, Kirby 3.10.0.1, and Kirby 4.1.1. Please update to one of these or a later version to fix the vulnerability.
In all of the mentioned releases, we have changed the URL field to only make the link button clickable if the entered URL is valid and safe.
Credits
Thanks to Natwara Archeepsamooth (@PlyNatwara) for responsibly reporting the identified issue.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | getkirby/cms | all versions | 3.6.6.5composer require getkirby/cms:^3.6.6.5 |
| 🐘Packagist | getkirby/cms | ≥ 3.7.0&&< 3.7.5.4 | 3.7.5.4composer require getkirby/cms:^3.7.5.4 |
| 🐘Packagist | getkirby/cms | ≥ 3.8.0&&< 3.8.4.3 | 3.8.4.3composer require getkirby/cms:^3.8.4.3 |
| 🐘Packagist | getkirby/cms | ≥ 3.9.0&&< 3.9.8.1 | 3.9.8.1composer require getkirby/cms:^3.9.8.1 |
| 🐘Packagist | getkirby/cms | ≥ 3.10.0&&< 3.10.0.1 | 3.10.0.1composer require getkirby/cms:^3.10.0.1 |
| 🐘Packagist | getkirby/cms | ≥ 4.0.0&&< 4.1.1 | 4.1.1composer require getkirby/cms:^4.1.1 |
Affected Products
kirbygetkirbyDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for getkirby/cms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update getkirby/cms to 3.6.6.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-26481 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2024-26481 in your dependencies?
Find it across Packagist, including transitive dependencies.