CVE-2024-26271 — release.portal.bom
HIGHCVE-2024-26271 is a high-severity (CVSS 8.8) Cross-Site Request Forgery (CSRF) vulnerability in com.liferay.portal:release.portal.bom. A fix is available for com.liferay.portal:release.portal.bom — see the affected versions and patch details below.
Liferay Portal and Liferay DXP Vulnerable to Cross-Site Request Forgery (CSRF) via the My Account Widget
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-26271.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
com.liferay.portal:release.portal.bom☕com.liferay.portal:release.dxp.bom☕com.liferay.portal:release.dxp.bom☕com.liferay.portal:release.dxp.bom☕com.liferay.portal:release.dxp.bomReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Cross-site request forgery (CSRF) vulnerability in the My Account widget in Liferay Portal 7.4.3.75 through 7.4.3.111, and Liferay DXP 2023.Q4.0 through 2023.Q4.2, 2023.Q3.1 through 2023.Q3.5, 7.4 update 75 through update 92 and 7.3 update 32 through update 36 allows remote attackers to (1) change user passwords, (2) shut down the server, (3) execute arbitrary code in the scripting console, (4) and perform other administrative actions via the _com_liferay_my_account_web_portlet_MyAccountPortlet_backURL parameter.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | com.liferay.portal:release.portal.bom | ≥ 7.4.3.75&&< 7.4.3.112 | 7.4.3.112com.liferay.portal:release.portal.bom:7.4.3.112 |
| ☕Maven | com.liferay.portal:release.dxp.bom | ≥ 2023.Q4.0&&< 2023.Q4.3 | 2023.Q4.3com.liferay.portal:release.dxp.bom:2023.Q4.3 |
| ☕Maven | com.liferay.portal:release.dxp.bom | ≥ 2023.Q3.1&&< 2023.Q3.6 | 2023.Q3.6com.liferay.portal:release.dxp.bom:2023.Q3.6 |
| ☕Maven | com.liferay.portal:release.dxp.bom | ≥ 7.3u32&&< 7.3u37 | 7.3u37com.liferay.portal:release.dxp.bom:7.3u37 |
| ☕Maven | com.liferay.portal:release.dxp.bom | ≥ 7.4u75&&< 7.4u93 | 7.4u93com.liferay.portal:release.dxp.bom:7.4u93 |
Affected Products
digital experience platformliferayliferay portalliferayDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for com.liferay.portal:release.portal.bom, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update com.liferay.portal:release.portal.bom to 7.4.3.112 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-26271 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2024-26271 in your dependencies?
Find it across Maven, including transitive dependencies.