NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2024-25981 — moodle

MEDIUMFix: moodle/moodle@1c059cb

CVE-2024-25981 is a medium-severity (CVSS 4.3) CWE-284 vulnerability in moodle/moodle. A fix is available for moodle/moodle — see the affected versions and patch details below.

Msa-24-0004: forum export did not respect activity group settings

Also known asBIT-moodle-2024-25981GHSA-jfrg-9hpq-9hvp
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-25981.

EPSS Exploitation Probability

via FIRST.org ↗
0.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs48th percentile — riskier than 48% of all scored CVEsHighest risk
0.00%0.36%0.72%1.08%0.3%0.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
🐘moodle/moodle🐘moodle/moodle🐘moodle/moodle

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Separate Groups mode restrictions were not honored when performing a forum export, which would export forum data for all groups. By default this only provided additional access to non-editing teachers.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmoodle/moodle≥ 4.3.0&&< 4.3.34.3.3composer require moodle/moodle:^4.3.3
🐘Packagistmoodle/moodle≥ 4.2.0&&< 4.2.64.2.6composer require moodle/moodle:^4.2.6
🐘Packagistmoodle/moodleall versions4.1.9composer require moodle/moodle:^4.1.9

Affected Products

2 products · 4 configurations
OS
fedorafedoraproject
1 version
38
Application
moodlemoodle
≥ 4.3.0 && < 4.3.3
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moodle/moodle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update moodle/moodle to 4.3.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-25981 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

Separate Groups mode restrictions were not honored when performing a forum export, which would export forum data for all groups. By default this only provided additional access to non-editing teachers.
O3 Security · Impact-Aware SCA

Is CVE-2024-25981 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2024-25981: moodle — Fixed in 4.3.3