NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

CVE-2024-25978 — moodle

HIGHFix: moodle/moodle@9ba1423

CVE-2024-25978 is a high-severity (CVSS 7.5) Uncontrolled Resource Consumption vulnerability in moodle/moodle. A fix is available for moodle/moodle — see the affected versions and patch details below.

Msa-24-0001: denial of service risk in file picker unzip functionality

Also known asBIT-moodle-2024-25978GHSA-487g-3m3v-hjhq
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Oct 28, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-25978.

EPSS Exploitation Probability

via FIRST.org ↗
0.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs61th percentile — riskier than 61% of all scored CVEsHighest risk
0.00%0.48%0.96%1.44%0.3%0.9%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
🐘moodle/moodle🐘moodle/moodle🐘moodle/moodle

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Insufficient file size checks resulted in a denial of service risk in the file picker's unzip functionality.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmoodle/moodle≥ 4.3.0&&< 4.3.34.3.3composer require moodle/moodle:^4.3.3
🐘Packagistmoodle/moodle≥ 4.2.0&&< 4.2.64.2.6composer require moodle/moodle:^4.2.6
🐘Packagistmoodle/moodleall versions4.1.9composer require moodle/moodle:^4.1.9

Affected Products

2 products · 4 configurations
OS
fedorafedoraproject
1 version
38
Application
moodlemoodle
≥ 4.3.0 && < 4.3.3
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moodle/moodle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update moodle/moodle to 4.3.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-25978 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Frequently Asked Questions

Insufficient file size checks resulted in a denial of service risk in the file picker's unzip functionality.
O3 Security · Impact-Aware SCA

Is CVE-2024-25978 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2024-25978: moodle DoS — Fixed in 4.3.3