CVE-2024-25637 — system
LOWCVE-2024-25637 is a low-severity (CVSS 3.1) Cross-site Scripting (XSS) vulnerability in october/system. A fix is available for october/system — see the affected versions and patch details below.
October System module has a Reflected XSS via X-October-Request-Handler Header
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-25637.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
october/systemReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Impact
The X-October-Request-Handler Header does not sanitize the AJAX handler name and allows unescaped HTML to be reflected back. There is no impact since this vulnerability cannot be exploited through normal browser interactions. This unescaped value is only detectable when using a proxy interception tool.
Patches
This issue has been patched in v3.5.15.
References
Credits to:
For more information
If you have any questions or comments about this advisory:
- Email us at [email protected]
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | october/system | ≥ 3.2&&< 3.5.15 | 3.5.15composer require october/system:^3.5.15 |
Affected Products
octoberoctobercmsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for october/system, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update october/system to 3.5.15 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-25637 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2024-25637 in your dependencies?
Find it across Packagist, including transitive dependencies.