NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2024-25602 — release.portal.bom

MEDIUM

CVE-2024-25602 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in com.liferay.portal:release.portal.bom. A fix is available for com.liferay.portal:release.portal.bom — see the affected versions and patch details below.

Liferay Portal and Liferay DXP's Users Admin module vulnerable to stored Cross-site Scripting

Also known asGHSA-v2xq-m22w-jmpr
Published
Updated
Affected
3 pkgs
Patched
2 / 3
Exploits
None indexed
Exploitation data as of Oct 28, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-25602.

EPSS Exploitation Probability

via FIRST.org ↗
0.6%probability of exploitation in next 30 days
Lower Risk-0.01%
Lower risk than most CVEs49th percentile — riskier than 49% of all scored CVEsHighest risk
0.00%0.37%0.75%1.12%0.2%0.6%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
☕com.liferay.portal:release.portal.bom☕com.liferay.portal:release.dxp.bom☕com.liferay.portal:release.dxp.bom

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Stored cross-site scripting (XSS) vulnerability in Users Admin module's edit user page in Liferay Portal 7.2.0 through 7.4.2, and older unsupported versions, and Liferay DXP 7.3 before service pack 3, 7.2 before fix pack 17, and older unsupported versions allows remote authenticated users to inject arbitrary web script or HTML via a crafted payload injected into an organization’s “Name” text field

Affected Packages

3 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavencom.liferay.portal:release.portal.bomall versionsNo fix
☕Mavencom.liferay.portal:release.dxp.bom≥ 7.3.0&&< 7.3.10.u47.3.10.u4com.liferay.portal:release.dxp.bom:7.3.10.u4
☕Mavencom.liferay.portal:release.dxp.bom≥ 7.2.0&&< 7.2.10.fp177.2.10.fp17com.liferay.portal:release.dxp.bom:7.2.10.fp17

Affected Products

2 products · 28 configurations
Application
digital experience platformliferay
< 7.2
2 versions
7.27.3
Application
liferay portalliferay
< 7.4.3.4
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for com.liferay.portal:release.portal.bom, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    A fix is available for CVE-2024-25602; check the affected-versions list above or the advisory for the patched release of com.liferay.portal:release.portal.bom, then make sure no transitive dependency still pins the vulnerable range.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Stored cross-site scripting (XSS) vulnerability in Users Admin module's edit user page in Liferay Portal 7.2.0 through 7.4.2, and older unsupported versions, and Liferay DXP 7.3 before service pack 3, 7.2 before fix pack 17, and older unsupported versions allows remote authenticated users to inject arbitrary web script or HTML via a crafted payload injected into an organization’s “Name” text field
O3 Security · Impact-Aware SCA

Is CVE-2024-25602 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2024-25602: release.portal XSS — Fixed in 7.3.10.u4