Your RSA-2048 keys break in 2030. Find every one of them before attackers do.
🛡️
Not in CISA KEV
CRITICAL severity

CVE-2024-25600 — Chocapikk

CRITICAL

CVE-2024-25600 is a critical-severity (CVSS 10) Code Injection vulnerability. 15 public exploit references exist, so weaponization risk is real. No vendor fix is recorded yet; mitigation options are listed below.

Improper Control of Generation of Code ('Code Injection') vulnerability in Codeer Limited Bricks Builder allows Code Injection.This issue affects Bricks Builder: from n/a through 1.9.6.

Published
Updated
Affected
—
Patched
—
Exploits
15 known
Exploitation data as of Oct 24, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • A successful exploit gives an attacker total control of the affected component, not partial access.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-25600.

EPSS Exploitation Probability

via FIRST.org ↗
88.2%probability of exploitation in next 30 days
Very High Risk0.00%
Lower risk than most CVEs100th percentile — riskier than 100% of all scored CVEsHighest risk
85.5%89.0%92.4%95.8%93.7%88.2%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

CVE-2024-25600 by exploitation likelihood (EPSS) against impact (CVSS). In the shaded patch-first corner (EPSS 50%+, CVSS 7.0+).

Where this sits among everything scored

Of 395,308 CVEs with a current EPSS score, this one falls in the 50–90% band (highlighted). Counts from FIRST.org, log-scaled.

Description

Improper Control of Generation of Code ('Code Injection') vulnerability in Codeer Limited Bricks Builder allows Code Injection.This issue affects Bricks Builder: from n/a through 1.9.6.

Exploits & PoCs
15

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

EDB-52619webappsmultiple

WordPress Bricks Builder Theme - RCE

by Jared Brits · Jul 7, 2026

Detection & mitigation playbook

Vulnerability
  1. Detect

    Identify every host running the affected component and compare the installed build against the fixed version below — for source-built or distro-packaged software the version string, not a lockfile, is the source of truth (`dpkg -l`, `rpm -q`, or the binary's own `--version`).

  2. Remediation status

    No fixed release is recorded for CVE-2024-25600 yet. Track the upstream advisory, and apply the exposure-reduction steps below in the meantime.

  3. Mitigate without a patch

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

How to detect CVE-2024-25600

A community-maintained Nuclei template exists for this CVE. You can scan for it directly:

nuclei -id cve-2024-25600 -u https://target
Template
Unauthenticated Remote Code Execution – Bricks <= 1.9.6
Severity
critical
Impact
Unauthenticated attackers can execute arbitrary code through the Bricks Builder theme, leading to complete site takeover and potential server compromise.
Remediation
Update Bricks Builder theme to version 1.9.7 or later.

Template by ProjectDiscovery nuclei-templates (christbowel), MIT licensed. View the full template. Scan only systems you are authorised to test.

Frequently Asked Questions

Improper Control of Generation of Code ('Code Injection') vulnerability in Codeer Limited Bricks Builder allows Code Injection.This issue affects Bricks Builder: from n/a through 1.9.6.
O3 Security · Impact-Aware SCA

Is CVE-2024-25600 in your dependencies?

Find it across , including transitive dependencies.

CVE-2024-25600: Chocapikk RCE (Critical 10)