CVE-2024-25120 is a medium-severity (CVSS 4.3) Information Exposure vulnerability in typo3/cms-core. A fix is available for typo3/cms-core — see the affected versions and patch details below.
Improper Access Control of Resources Referenced by t3:// URI Scheme in TYPO3
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-25120.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
typo3/cms-core🐘typo3/cms-core🐘typo3/cms-core🐘typo3/cms-core🐘typo3/cms-core🐘typo3/cms-coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Problem
The TYPO3-specific t3:// URI scheme could be used to access resources outside of the users' permission scope. This encompassed files, folders, pages, and records (although only if a valid link-handling configuration was provided). Exploiting this vulnerability requires a valid backend user account.
Solution
Update to TYPO3 versions 8.7.57 ELTS, 9.5.46 ELTS, 10.4.43 ELTS, 11.5.35 LTS, 12.4.11 LTS, 13.0.1 that fix the problem described.
Credits
Thanks to Richie Lee who reported this issue and to TYPO3 core & security team member Benjamin Franzke who fixed the issue.
References
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | typo3/cms-core | ≥ 8.0.0&&< 8.7.57 | 8.7.57composer require typo3/cms-core:^8.7.57 |
| 🐘Packagist | typo3/cms-core | ≥ 9.0.0&&< 9.5.46 | 9.5.46composer require typo3/cms-core:^9.5.46 |
| 🐘Packagist | typo3/cms-core | ≥ 10.0.0&&< 10.4.43 | 10.4.43composer require typo3/cms-core:^10.4.43 |
| 🐘Packagist | typo3/cms-core | ≥ 11.0.0&&< 11.5.35 | 11.5.35composer require typo3/cms-core:^11.5.35 |
| 🐘Packagist | typo3/cms-core | ≥ 12.0.0&&< 12.4.11 | 12.4.11composer require typo3/cms-core:^12.4.11 |
| 🐘Packagist | typo3/cms-core | ≥ 13.0.0&&< 13.0.1 | 13.0.1composer require typo3/cms-core:^13.0.1 |
Affected Products
typo3typo3Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for typo3/cms-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update typo3/cms-core to 8.7.57 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-25120 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2024-25120 in your dependencies?
Find it across Packagist, including transitive dependencies.