CVE-2024-24773 — apache-superset
MEDIUMCVE-2024-24773 is a medium-severity (CVSS 4.9) CWE-863 vulnerability in apache-superset. A fix is available for apache-superset — see the affected versions and patch details below.
Apache Superset: Improper validation of SQL statements allows for unauthorized access to data
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-24773.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
apache-superset🐍apache-supersetReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Improper parsing of nested SQL statements on SQLLab would allow authenticated users to surpass their data authorization scope. This issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1.
Users are recommended to upgrade to version 3.1.1, which fixes the issue.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | apache-superset | all versions | 3.0.4pip install --upgrade 'apache-superset==3.0.4' |
| 🐍PyPI | apache-superset | ≥ 3.1.0&&< 3.1.1 | 3.1.1pip install --upgrade 'apache-superset==3.1.1' |
Affected Products
supersetapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for apache-superset, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update apache-superset to 3.0.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-24773 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2024-24773 in your dependencies?
Find it across PyPI, including transitive dependencies.