CVE-2024-24753 is a medium-severity (CVSS 4.8) CWE-436 vulnerability in bref/bref. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for bref/bref — see the affected versions and patch details below.
Bref Multiple Value Headers Not Supported in ApiGatewayFormatV2
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-24753.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
bref/brefReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Impacted Resources
bref/src/Event/Http/HttpResponse.php:61-90
Description
When Bref is used in combination with an API Gateway with the v2 format, it does not handle multiple values headers.
Precisely, if PHP generates a response with two headers having the same key but different values only the latest one is kept.
Impact
If an application relies on multiple headers with the same key being set for security reasons, then Bref would lower the application security.
For example, if an application sets multiple Content-Security-Policy headers, then Bref would just reflect the latest one.
PoC
- Create a new Bref project.
- Create an
index.phpfile with the following content:
<?php
header("Content-Security-Policy: script-src 'none'", false);
header("Content-Security-Policy: img-src 'self'", false);
?>
<script>alert(document.domain)</script>
<img src="https://bref.sh/favicon-32x32.png">
- Use the following
serverless.ymlto deploy the Lambda:
service: app
provider:
name: aws
region: eu-central-1
plugins:
- ./vendor/bref/bref
functions:
api:
handler: index.php
description: ''
runtime: php-81-fpm
timeout: 28 # in seconds (API Gateway has a timeout of 29 seconds)
events:
- httpApi: '*'
# Exclude files from deployment
package:
patterns:
- '!node_modules/**'
- '!tests/**'
- Browse the Lambda URL.
- Notice that the JavaScript code is executed as the
Content-Security-Policy: script-src 'none'header has been removed. - Notice that the external image has not been loaded as the
Content-Security-Policy: img-src 'self'header has been kept. - Start a PHP server inside the project directory (e.g.
php -S 127.0.0.1:8090). - Browse the
index.phpscript through the PHP server (e.g. http://127.0.0.1:8090/index.php). - Notice that the JavaScript code is not executed as the
Content-Security-Policy: script-src 'none'header has been kept. - Notice that the external image has not been loaded as the
Content-Security-Policy: img-src 'self'header has been kept.
Suggested Remediation
Concatenate all the multiple value headers' values with a comma (,) as separator and return a single header with all the values to the API Gateway.
References
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | bref/bref | all versions | 2.1.13composer require bref/bref:^2.1.13 |
Affected Products
brefmnapoliResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for bref/bref, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update bref/bref to 2.1.13 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-24753 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2024-24753 in your dependencies?
Find it across Packagist, including transitive dependencies.