CVE-2024-24751 is a medium-severity (CVSS 4.3) CWE-284 vulnerability in derhansen/sf_event_mgt. A fix is available for derhansen/sf_event_mgt — see the affected versions and patch details below.
Broken Access Control in Backend Module in sf_event_mgt
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-24751.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
derhansen/sf_event_mgtReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
sf_event_mgt is an event management and registration extension for the TYPO3 CMS based on ExtBase and Fluid. In affected versions the existing access control check for events in the backend module got broken during the update of the extension to TYPO3 12.4, because the RedirectResponse from the $this->redirect() function was never handled. This issue has been addressed in version 7.4.0. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | derhansen/sf_event_mgt | ≥ 7.0.0&&< 7.4.0 | 7.4.0composer require derhansen/sf_event_mgt:^7.4.0 |
Affected Products
event management and registrationderhansenDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for derhansen/sf_event_mgt, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update derhansen/sf_event_mgt to 7.4.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-24751 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2024-24751 in your dependencies?
Find it across Packagist, including transitive dependencies.