CVE-2024-23686 — dependency-check-ant
MEDIUMCVE-2024-23686 is a medium-severity (CVSS 5.3) CWE-532 vulnerability in org.owasp:dependency-check-ant. A fix is available for org.owasp:dependency-check-ant — see the affected versions and patch details below.
DependencyCheck Debug Mode Logging of NVD API Key
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-23686.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.owasp:dependency-check-ant☕org.owasp:dependency-check-cli☕org.owasp:dependency-check-mavenReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
DependencyCheck for Maven 9.0.0 to 9.0.6, for CLI version 9.0.0 to 9.0.5, and for Ant versions 9.0.0 to 9.0.5, when used in debug mode, allows an attacker to recover the NVD API Key from a log file.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.owasp:dependency-check-ant | ≥ 9.0.0&&< 9.0.6 | 9.0.6org.owasp:dependency-check-ant:9.0.6 |
| ☕Maven | org.owasp:dependency-check-cli | ≥ 9.0.0&&< 9.0.6 | 9.0.6org.owasp:dependency-check-cli:9.0.6 |
| ☕Maven | org.owasp:dependency-check-maven | ≥ 9.0.0&&< 9.0.6 | 9.0.6org.owasp:dependency-check-maven:9.0.6 |
Affected Products
dependency-checkowaspDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.owasp:dependency-check-ant, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.owasp:dependency-check-ant to 9.0.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-23686 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2024-23686 in your dependencies?
Find it across Maven, including transitive dependencies.