CVE-2024-23114 is a critical-severity (CVSS 9.8) Deserialization of Untrusted Data vulnerability in org.apache.camel:camel-cassandraql. A fix is available for org.apache.camel:camel-cassandraql — see the affected versions and patch details below.
Apache Camel: Camel-CassandraQL: Unsafe Deserialization from CassandraAggregationRepository
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-23114.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.camel:camel-cassandraql☕org.apache.camel:camel-cassandraql☕org.apache.camel:camel-cassandraql☕org.apache.camel:camel-cassandraqlReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Deserialization of Untrusted Data vulnerability in Apache Camel CassandraQL Component AggregationRepository which is vulnerable to unsafe deserialization. Under specific conditions it is possible to deserialize malicious payload.This issue affects Apache Camel: from 3.0.0 before 3.21.4, from 3.22.0 before 3.22.1, from 4.0.0 before 4.0.4, from 4.1.0 before 4.4.0.
Users are recommended to upgrade to version 4.4.0, which fixes the issue. If users are on the 4.0.x LTS releases stream, then they are suggested to upgrade to 4.0.4. If users are on 3.x, they are suggested to move to 3.21.4 or 3.22.1
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.camel:camel-cassandraql | ≥ 3.0.0&&< 3.21.4 | 3.21.4org.apache.camel:camel-cassandraql:3.21.4 |
| ☕Maven | org.apache.camel:camel-cassandraql | ≥ 3.22.0&&< 3.22.1 | 3.22.1org.apache.camel:camel-cassandraql:3.22.1 |
| ☕Maven | org.apache.camel:camel-cassandraql | ≥ 4.0.0&&< 4.0.4 | 4.0.4org.apache.camel:camel-cassandraql:4.0.4 |
| ☕Maven | org.apache.camel:camel-cassandraql | ≥ 4.1.0&&< 4.4.0 | 4.4.0org.apache.camel:camel-cassandraql:4.4.0 |
Affected Products
camelapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.camel:camel-cassandraql, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.camel:camel-cassandraql to 3.21.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-23114 is resolved across your whole dependency graph.
Workarounds
Do not deserialise data from untrusted sources: where the format allows it, restrict deserialisation to an explicit allowlist of expected types, and prefer a data-only format (JSON, Protobuf) over one that can reconstruct arbitrary objects until you can upgrade.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| RHINT Camel-K 1.10.8 | org.apache.camel-camel-cassandraql | RHSA-2024:8339 |
Frequently Asked Questions
Is CVE-2024-23114 in your dependencies?
Find it across Maven, including transitive dependencies.