NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2024-22369 — camel-sql

HIGHFix: apache/camel#12706

CVE-2024-22369 is a high-severity (CVSS 7.8) Deserialization of Untrusted Data vulnerability in org.apache.camel:camel-sql. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for org.apache.camel:camel-sql — see the affected versions and patch details below.

Apache Camel: Camel-SQL: Unsafe Deserialization from JDBCAggregationRepository

Also known asGHSA-36xr-4x2f-cfj9
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
2 known
Exploitation data as of Oct 27, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-22369.

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs55th percentile — riskier than 55% of all scored CVEsHighest risk
0.00%5.12%10.2%15.3%4.8%0.7%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
☕org.apache.camel:camel-sql☕org.apache.camel:camel-sql☕org.apache.camel:camel-sql☕org.apache.camel:camel-sql

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Deserialization of Untrusted Data vulnerability in Apache Camel SQL Component. This issue affects Apache Camel: from 3.0.0 before 3.21.4, from 3.22.0 before 3.22.1, from 4.0.0 before 4.0.4, from 4.1.0 before 4.4.0.

Users are recommended to upgrade to version 4.4.0, which fixes the issue. If users are on the 4.0.x LTS releases stream, then they are suggested to upgrade to 4.0.4. If users are on 3.x, they are suggested to move to 3.21.4 or 3.22.1

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.camel:camel-sql≥ 3.0.0&&< 3.21.43.21.4org.apache.camel:camel-sql:3.21.4
☕Mavenorg.apache.camel:camel-sql≥ 3.22.0&&< 3.22.13.22.1org.apache.camel:camel-sql:3.22.1
☕Mavenorg.apache.camel:camel-sql≥ 4.0.0&&< 4.0.44.0.4org.apache.camel:camel-sql:4.0.4
☕Mavenorg.apache.camel:camel-sql≥ 4.1.0&&< 4.4.04.4.0org.apache.camel:camel-sql:4.4.0

Affected Products

1 product · 4 configurations
Application
camelapache
≥ 4.1.0 && < 4.4.0
1 version
3.22.0
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.camel:camel-sql, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.camel:camel-sql to 3.21.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-22369 is resolved across your whole dependency graph.

  3. Workarounds

    Do not deserialise data from untrusted sources: where the format allows it, restrict deserialisation to an explicit allowlist of expected types, and prefer a data-only format (JSON, Protobuf) over one that can reconstruct arbitrary objects until you can upgrade.

Frequently Asked Questions

Deserialization of Untrusted Data vulnerability in Apache Camel SQL Component. This issue affects Apache Camel: from 3.0.0 before 3.21.4, from 3.22.0 before 3.22.1, from 4.0.0 before 4.0.4, from 4.1.0 before 4.4.0. Users are recommended to upgrade to version 4.4.0, which fixes the issue. If users are on the 4.0.x LTS releases stream, then they are suggested to upgrade to 4.0.4. If users are on 3.x, they are suggested to move to 3.21.4 or 3.22.1
O3 Security · Impact-Aware SCA

Is CVE-2024-22369 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2024-22369: camel-sql Deserialization — Fixed in 3.21.4