CVE-2024-22205 is a critical-severity (CVSS 9.1) Server-Side Request Forgery (SSRF) vulnerability in whoogle-search. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for whoogle-search — see the affected versions and patch details below.
Whoogle Search Server Side Request Forgery vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
whoogle-searchReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Whoogle Search is a self-hosted metasearch engine. In versions 0.8.3 and prior, the window endpoint does not sanitize user-supplied input from the location variable and passes it to the send method which sends a GET request on lines 339-343 in request.py, which leads to a server-side request forgery. This issue allows for crafting GET requests to internal and external resources on behalf of the server. For example, this issue would allow for accessing resources on the internal network that the server has access to, even though these resources may not be accessible on the internet. This issue is fixed in version 0.8.4.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | whoogle-search | all versions | 0.8.4pip install --upgrade 'whoogle-search==0.8.4' |
Affected Products
whoogle searchbenbusbyResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for whoogle-search, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update whoogle-search to 0.8.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-22205 is resolved across your whole dependency graph.
Workarounds
Restrict outbound requests from the affected component to an allowlist of hosts, block access to link-local and internal address ranges at the network layer, and require authentication on internal services so a forged request cannot reach them unauthenticated.
Frequently Asked Questions
Is CVE-2024-22205 in your dependencies?
Find it across PyPI, including transitive dependencies.