CVE-2024-21651 — xwiki-platform-distributi…
HIGHCVE-2024-21651 is a high-severity (CVSS 7.5) Uncontrolled Resource Consumption vulnerability in org.xwiki.platform:xwiki-platform-distribution-war. A fix is available for org.xwiki.platform:xwiki-platform-distribution-war — see the affected versions and patch details below.
XWiki Denial of Service attack through attachments
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-21651.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.xwiki.platform:xwiki-platform-distribution-war☕org.xwiki.platform:xwiki-platform-distribution-war☕org.xwiki.platform:xwiki-platform-distribution-warReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Impact
A user able to attach a file to a page can post a malformed TAR file by manipulating file modification times headers, which when parsed by Tika, could cause a denial of service issue via CPU consumption.
Patches
This vulnerability has been patched in XWiki 14.10.18, 15.5.3 and 15.8 RC1.
Workarounds
The workaround is to download commons-compress 1.24 and replace the one located in XWiki WEB-INF/lib/ folder.
References
https://jira.xwiki.org/browse/XCOMMONS-2796
For more information
If you have any questions or comments about this advisory:
- Open an issue in Jira XWiki.org
- Email us at Security Mailing List
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.xwiki.platform:xwiki-platform-distribution-war | ≥ 14.10&&< 14.10.18 | 14.10.18org.xwiki.platform:xwiki-platform-distribution-war:14.10.18 |
| ☕Maven | org.xwiki.platform:xwiki-platform-distribution-war | ≥ 15.0-rc-1&&< 15.5.3 | 15.5.3org.xwiki.platform:xwiki-platform-distribution-war:15.5.3 |
| ☕Maven | org.xwiki.platform:xwiki-platform-distribution-war | ≥ 15.6-rc-1&&< 15.8-rc-1 | 15.8-rc-1org.xwiki.platform:xwiki-platform-distribution-war:15.8-rc-1 |
Affected Products
xwikixwikiDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.xwiki.platform:xwiki-platform-distribution-war, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.xwiki.platform:xwiki-platform-distribution-war to 14.10.18 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-21651 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Frequently Asked Questions
Is CVE-2024-21651 in your dependencies?
Find it across Maven, including transitive dependencies.