NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
LOW severity

CVE-2024-1979 — quarkus-kubernetes-deploy…

LOWFix: quarkusio/quarkus@3a3b0d7

CVE-2024-1979 is a low-severity (CVSS 3.5) Information Exposure vulnerability in io.quarkus:quarkus-kubernetes-deployment. A fix is available for io.quarkus:quarkus-kubernetes-deployment — see the affected versions and patch details below.

Quarkus: information leak in annotation

Also known asGHSA-7g97-7r3c-5cc6
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 26, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-1979.

EPSS Exploitation Probability

via FIRST.org ↗
0.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs48th percentile — riskier than 48% of all scored CVEsHighest risk
0.00%0.37%0.73%1.10%0.1%0.6%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕io.quarkus:quarkus-kubernetes-deployment

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

A vulnerability was found in Quarkus. In certain conditions related to the CI process, git credentials could be inadvertently published, which could put the git repository at risk.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenio.quarkus:quarkus-kubernetes-deploymentall versions3.7.3io.quarkus:quarkus-kubernetes-deployment:3.7.3

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for io.quarkus:quarkus-kubernetes-deployment, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update io.quarkus:quarkus-kubernetes-deployment to 3.7.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-1979 is resolved across your whole dependency graph.

  3. Workarounds

    Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate

Three conditions are required to enable this vulnerability: 1) If you are in an environment where you have a token in the Git URL of the Quarkus project you are building 2) If you build with a Quarkus extension that generates a Kubernetes descriptor (for instance a Kubernetes or OpenShift extension) 3) If this…

Workaround published by Red Hat
Ensure that at least one of the preconditions is not present in your environment.
Source: Red Hat security advisory for CVE-2024-1979 (CC BY 4.0)
ProductFixed inAdvisory
Red Hat build of Quarkus 3.2.11.Finalio.quarkus/quarkus-kubernetes-deployment:3.2.11.Final-redhat-00001RHSA-2024:1662

Frequently Asked Questions

A vulnerability was found in Quarkus. In certain conditions related to the CI process, git credentials could be inadvertently published, which could put the git repository at risk.
O3 Security · Impact-Aware SCA

Is CVE-2024-1979 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2024-1979: quarkus-kubernetes — Fixed in 3.7.3