NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

CVE-2024-1483 — mlflow

HIGH

CVE-2024-1483 is a high-severity (CVSS 7.5) Path Traversal vulnerability in mlflow. A fix is available for mlflow — see the affected versions and patch details below.

Path Traversal Vulnerability in mlflow/mlflow

Also known asBIT-mlflow-2024-1483GHSA-f82r-jj5r-6g97PYSEC-2026-1650
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-1483.

EPSS Exploitation Probability

via FIRST.org ↗
2.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs86th percentile — riskier than 86% of all scored CVEsHighest risk
0.00%32.2%64.5%96.7%75.0%2.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍mlflow

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

A path traversal vulnerability exists in mlflow/mlflow version 2.9.2, allowing attackers to access arbitrary files on the server. By crafting a series of HTTP POST requests with specially crafted 'artifact_location' and 'source' parameters, using a local URI with '#' instead of '?', an attacker can traverse the server's directory structure. The issue occurs due to insufficient validation of user-supplied input in the server's handlers.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPImlflowall versions2.12.1pip install --upgrade 'mlflow==2.12.1'

Affected Products

1 product · 1 configurations
Application
mlflowlfprojects
< 2.12.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for mlflow, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update mlflow to 2.12.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-1483 is resolved across your whole dependency graph.

  3. Workarounds

    Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.

How to detect CVE-2024-1483

A community-maintained Nuclei template exists for this CVE. You can scan for it directly:

nuclei -id cve-2024-1483 -u https://target
Template
Mlflow < 2.9.2 - Path Traversal
Severity
high
Impact
Successful exploitation could be lead to disclose of sensitive information such as SSH Keys or Internal configurations.
Remediation
To fix this vulnerability, it is important to update the mlflow package to the latest version 2.10.0.

Template by ProjectDiscovery nuclei-templates (gy741), MIT licensed. View the full template. Scan only systems you are authorised to test.

Frequently Asked Questions

A path traversal vulnerability exists in mlflow/mlflow version 2.9.2, allowing attackers to access arbitrary files on the server. By crafting a series of HTTP POST requests with specially crafted 'artifact_location' and 'source' parameters, using a local URI with '#' instead of '?', an attacker can traverse the server's directory structure. The issue occurs due to insufficient validation of user-supplied input in the server's handlers.
O3 Security · Impact-Aware SCA

Is CVE-2024-1483 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2024-1483: mlflow Path Traversal — Fixed in 2.12.1