CVE-2024-1442 — grafana
MEDIUMCVE-2024-1442 is a medium-severity (CVSS 6) Improper Privilege Management vulnerability in github.com/grafana/grafana. A fix is available for github.com/grafana/grafana — see the affected versions and patch details below.
User with permissions to create a data source can CRUD all data sources
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-1442.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/grafana/grafana🐹github.com/grafana/grafana🐹github.com/grafana/grafana🐹github.com/grafana/grafana🐹github.com/grafana/grafanaReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
A user with the permissions to create a data source can use Grafana API to create a data source with UID set to *. Doing this will grant the user access to read, query, edit and delete all data sources within the organization.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/grafana/grafana | ≥ 8.5.0&&< 9.5.7 | 9.5.7go get github.com/grafana/grafana@v9.5.7 |
| 🐹Go | github.com/grafana/grafana | ≥ 10.0.0&&< 10.0.12 | 10.0.12go get github.com/grafana/grafana@v10.0.12 |
| 🐹Go | github.com/grafana/grafana | ≥ 10.1.0&&< 10.1.8 | 10.1.8go get github.com/grafana/grafana@v10.1.8 |
| 🐹Go | github.com/grafana/grafana | ≥ 10.2.0&&< 10.2.5 | 10.2.5go get github.com/grafana/grafana@v10.2.5 |
| 🐹Go | github.com/grafana/grafana | ≥ 10.3.0&&< 10.3.4 | 10.3.4go get github.com/grafana/grafana@v10.3.4 |
Affected Products
grafanagrafanaDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/grafana/grafana, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/grafana/grafana to 9.5.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-1442 is resolved across your whole dependency graph.
Workarounds
Close the privilege gap rather than the entry point: audit which accounts, roles and service identities can reach the affected operation, drop the component to the least privilege it actually needs, and review file and directory permissions created by earlier installs — a default left in place is what makes this reachable.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
The issue of allowing users to set the UID to '*' via the Grafana API presents a moderate severity concern due to its potential impact on data integrity and security within the organization's Grafana instance. While the risk of unauthorized access and data manipulation is significant, its severity is tempered by the…
Mitigation for this issue is either not available or the currently available options don't meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.Source: Red Hat security advisory for CVE-2024-1442 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Advanced Cluster Management for Kubernetes 2.12 for RHEL 9 | rhacm2/acm-cli-rhel9:v2.12.0-17 | RHSA-2024:8974 |
| Red Hat Ceph Storage 5.3 | rhceph/keepalived-rhel8:2.1.5-44 | RHBA-2025:1479 |
| Red Hat Ceph Storage 6.1 | rhceph/rhceph-6-dashboard-rhel9:6-90 | RHSA-2024:2633 |
Frequently Asked Questions
Is CVE-2024-1442 in your dependencies?
Find it across Go, including transitive dependencies.