CVE-2023-7272 is a high-severity (CVSS 8.6) Out-of-bounds Write vulnerability in org.eclipse.parsson:parsson. A fix is available for org.eclipse.parsson:parsson — see the affected versions and patch details below.
Eclipse Parsson stack overflow with deeply nested objects
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-7272.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.eclipse.parsson:parsson☕org.eclipse.parsson:parssonReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
In Eclipse Parsson before 1.0.4 and 1.1.3, a document with a large depth of nested objects can allow an attacker to cause a Java stack overflow exception and denial of service. Eclipse Parsson allows processing (e.g. parse, generate, transform and query) JSON documents.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.eclipse.parsson:parsson | ≥ 1.1.0&&< 1.1.3 | 1.1.3org.eclipse.parsson:parsson:1.1.3 |
| ☕Maven | org.eclipse.parsson:parsson | all versions | 1.0.4org.eclipse.parsson:parsson:1.0.4 |
Affected Products
parssoneclipseDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.eclipse.parsson:parsson, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.eclipse.parsson:parsson to 1.1.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-7272 is resolved across your whole dependency graph.
Workarounds
Stop feeding it untrusted input: reject or quarantine files and payloads from unverified sources until you can upgrade, restrict accepted formats to the ones you actually need, and run the parsing or decoding step in a least-privileged sandbox or short-lived worker so a crash or corrupted read cannot reach the rest of the process.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Moderate impact: Red Hat products using Eclipse Parsson can be exposed to denial of service when an attacker sends a JSON document with a very large nesting depth and the product processes it; parsing the nested objects can trigger a Java stack overflow exception. Red Hat's CVSS is 6.8 (Moderate;…
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base, or stability.Source: Red Hat security advisory for CVE-2023-7272 (CC BY 4.0)
Frequently Asked Questions
Is CVE-2023-7272 in your dependencies?
Find it across Maven, including transitive dependencies.