NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
CRITICAL severity

CVE-2023-6940 — mlflow

CRITICALFix: mlflow/mlflow@5139b10

CVE-2023-6940 is a critical-severity (CVSS 9) CWE-77 vulnerability in mlflow. A fix is available for mlflow — see the affected versions and patch details below.

Command Injection

Also known asBIT-mlflow-2023-6940GHSA-hvc6-42vf-jhf8PYSEC-2026-1652
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 23, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2023-6940.

EPSS Exploitation Probability

via FIRST.org ↗
1.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs68th percentile — riskier than 68% of all scored CVEsHighest risk
0.00%0.57%1.15%1.72%0.2%1.2%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍mlflow

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

with only one user interaction(download a malicious config), attackers can gain full command execution on the victim system.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPImlflowall versions2.9.2pip install --upgrade 'mlflow==2.9.2'

Affected Products

1 product · 1 configurations
Application
mlflowlfprojects
< 2.9.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for mlflow, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update mlflow to 2.9.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-6940 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Frequently Asked Questions

with only one user interaction(download a malicious config), attackers can gain full command execution on the victim system.
O3 Security · Impact-Aware SCA

Is CVE-2023-6940 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2023-6940: mlflow — Fixed in 2.9.2