NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

CVE-2023-6909 — mlflow

HIGHFix: mlflow/mlflow@1da75df

CVE-2023-6909 is a high-severity (CVSS 7.5) CWE-29 vulnerability in mlflow. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for mlflow — see the affected versions and patch details below.

Path Traversal: '\..\filename' in mlflow/mlflow

Also known asBIT-mlflow-2023-6909GHSA-5r3q-93q3-f978PYSEC-2023-252
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
89.7%probability of exploitation in next 30 days
Very High Risk0.00%
Lower risk than most CVEs100th percentile — riskier than 100% of all scored CVEsHighest risk
84.5%86.6%88.8%90.9%85.7%89.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍mlflow

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Path Traversal: '..\filename' in GitHub repository mlflow/mlflow prior to 2.9.2.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPImlflowall versions2.9.2pip install --upgrade 'mlflow==2.9.2'

Affected Products

1 product · 1 configurations
Application
mlflowlfprojects
< 2.9.2
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for mlflow, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update mlflow to 2.9.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-6909 is resolved across your whole dependency graph.

  3. Workarounds

    Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.

How to detect CVE-2023-6909

A community-maintained Nuclei template exists for this CVE. You can scan for it directly:

nuclei -id cve-2023-6909 -u https://target
Template
Mlflow <2.9.2 - Path Traversal
Severity
high
Impact
Successful exploitation could be lead to disclose of sensitive information such as SSH Keys or Internal configurations.
Remediation
To fix this vulnerability, it is important to update the mlflow package to the latest version 2.10.0.

Template by ProjectDiscovery nuclei-templates (Hyunsoo-ds), MIT licensed. View the full template. Scan only systems you are authorised to test.

Frequently Asked Questions

Path Traversal: '\..\filename' in GitHub repository mlflow/mlflow prior to 2.9.2.
O3 Security · Impact-Aware SCA

Is CVE-2023-6909 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2023-6909: mlflow Path Traversal — Fixed in 2.9.2