NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
CRITICAL severity

CVE-2023-6730 — transformers

CRITICALFix: huggingface/transformers@1d63b0e

CVE-2023-6730 is a critical-severity (CVSS 9) Deserialization of Untrusted Data vulnerability in transformers. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for transformers — see the affected versions and patch details below.

Deserialization of Untrusted Data in huggingface/transformers

Also known asGHSA-3863-2447-669pPYSEC-2023-300
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs61th percentile — riskier than 61% of all scored CVEsHighest risk
0.00%0.48%0.95%1.43%0.2%0.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍transformers

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Deserialization of Untrusted Data in GitHub repository huggingface/transformers prior to 4.36.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPItransformersall versions4.36.0pip install --upgrade 'transformers==4.36.0'

Affected Products

1 product · 1 configurations
Application
transformershuggingface
< 4.36.0
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for transformers, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update transformers to 4.36.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-6730 is resolved across your whole dependency graph.

  3. Workarounds

    Do not deserialise data from untrusted sources: where the format allows it, restrict deserialisation to an explicit allowlist of expected types, and prefer a data-only format (JSON, Protobuf) over one that can reconstruct arbitrary objects until you can upgrade.

Frequently Asked Questions

Deserialization of Untrusted Data in GitHub repository huggingface/transformers prior to 4.36.
O3 Security · Impact-Aware SCA

Is CVE-2023-6730 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2023-6730: transformers — Fixed in 4.36.0