CVE-2023-6544 — keycloak-services
MEDIUMCVE-2023-6544 is a medium-severity (CVSS 5.4) CWE-625 vulnerability in org.keycloak:keycloak-services. A fix is available for org.keycloak:keycloak-services — see the affected versions and patch details below.
Keycloak: authorization bypass
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-6544.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.keycloak:keycloak-services☕org.keycloak:keycloak-servicesReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Due to a permissive regular expression hardcoded for filtering allowed hosts to register a dynamic client, a malicious user with enough information about the environment could benefit and jeopardize an environment with this specific Dynamic Client Registration with TrustedDomain configuration previously unauthorized.
Acknowledgements:
Special thanks to Bastian Kanbach for reporting this issue and helping us improve our security.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.keycloak:keycloak-services | all versions | 22.0.10org.keycloak:keycloak-services:22.0.10 |
| ☕Maven | org.keycloak:keycloak-services | ≥ 23.0.0&&< 24.0.3 | 24.0.3org.keycloak:keycloak-services:24.0.3 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.keycloak:keycloak-services, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.keycloak:keycloak-services to 22.0.10 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-6544 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Due to the high complexity of this attack, Red Hat considers this a Moderate impact.
No mitigation is currently available for this flaw.Source: Red Hat security advisory for CVE-2023-6544 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat build of Keycloak 22 | rhbk/keycloak-operator-bundle:22.0.10-1 | RHSA-2024:1867 |
| Red Hat build of Keycloak 22.0.10 | keycloak-core | RHSA-2024:1868 |
| Red Hat Single Sign-On 7.6 for RHEL 7 | rh-sso7-keycloak-0:18.0.13-1.redhat_00001.1.el7sso | RHSA-2024:1860 |
| Red Hat Single Sign-On 7.6 for RHEL 8 | rh-sso7-keycloak-0:18.0.13-1.redhat_00001.1.el8sso | RHSA-2024:1861 |
| Red Hat Single Sign-On 7.6 for RHEL 9 | rh-sso7-keycloak-0:18.0.13-1.redhat_00001.1.el9sso | RHSA-2024:1862 |
| RHEL-8 based Middleware Containers | rh-sso-7/sso76-openshift-rhel8:7.6-46 | RHSA-2024:1864 |
| RHSSO 7.6.8 | rh-sso7-keycloak | RHSA-2024:1866 |
Frequently Asked Questions
Is CVE-2023-6544 in your dependencies?
Find it across Maven, including transitive dependencies.