CVE-2023-6481 is a high-severity (CVSS 7.1) vulnerability in ch.qos.logback:logback-core. A fix is available for ch.qos.logback:logback-core — see the affected versions and patch details below.
Logback "receiver" DOS vulnerability CVE-2023-6378 incomplete fix
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
ch.qos.logback:logback-core☕ch.qos.logback:logback-core☕ch.qos.logback:logback-coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
A serialization vulnerability in logback receiver component part of logback version 1.4.13, 1.3.13 and 1.2.12 allows an attacker to mount a Denial-Of-Service attack by sending poisoned data.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | ch.qos.logback:logback-core | ≥ 1.4.13&&< 1.4.14 | 1.4.14ch.qos.logback:logback-core:1.4.14 |
| ☕Maven | ch.qos.logback:logback-core | ≥ 1.3.13&&< 1.3.14 | 1.3.14ch.qos.logback:logback-core:1.3.14 |
| ☕Maven | ch.qos.logback:logback-core | ≥ 1.2.12&&< 1.2.13 | 1.2.13ch.qos.logback:logback-core:1.2.13 |
Affected Products
logbackqosDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ch.qos.logback:logback-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update ch.qos.logback:logback-core to 1.4.14 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-6481 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
The security vulnerability in the logback package is considered of moderate severity due to its potential for facilitating a denial-of-service (DoS) attack. While a DoS attack can disrupt service availability, this vulnerability may not lead to more severe consequences such as unauthorized access or data breaches.
Mitigation for this issue is either not available or the currently available options don't meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.Source: Red Hat security advisory for CVE-2023-6481 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat AMQ Broker 7 | logback | RHSA-2024:2945 |
| Red Hat Fuse 7.13.0 | logback | RHSA-2024:3354 |
| RHINT Camel-Springboot 4.0.3 | logback | RHSA-2024:0793 |
| RHOSS-1.31-RHEL-8 | openshift-serverless-1/client-kn-rhel8:1.10.0-5 | RHSA-2024:0843 |
| RHPAM 7.13.5 async | see advisory | RHSA-2024:1353 |
Frequently Asked Questions
Is CVE-2023-6481 in your dependencies?
Find it across Maven, including transitive dependencies.