CVE-2023-6149 is a medium-severity (CVSS 5.7) XML External Entity (XXE) vulnerability in com.qualys.plugins:qualys-was. A fix is available for com.qualys.plugins:qualys-was — see the affected versions and patch details below.
Qualys Jenkins Plugin for WAS XML External Entity vulnerability
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-6149.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
com.qualys.plugins:qualys-wasReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Qualys Jenkins Plugin for WAS prior to version and including 2.0.11 was identified to be affected by a security flaw, which was missing a permission check while performing a connectivity check to Qualys Cloud Services. This allowed any user with login access to configure or edit jobs to utilize the plugin and configure potential a rouge endpoint via which it was possible to control response for certain request which could be injected with XXE payloads leading to XXE while processing the response data
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | com.qualys.plugins:qualys-was | all versions | 2.0.12com.qualys.plugins:qualys-was:2.0.12 |
Affected Products
web application screeningqualysDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for com.qualys.plugins:qualys-was, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update com.qualys.plugins:qualys-was to 2.0.12 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-6149 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2023-6149 in your dependencies?
Find it across Maven, including transitive dependencies.