NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
CRITICAL severity

CVE-2023-6015 — mlflow

CRITICALFix: mlflow/mlflow#10330

CVE-2023-6015 is a critical-severity (CVSS 10) Path Traversal vulnerability in mlflow. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for mlflow — see the affected versions and patch details below.

MLflow Arbitrary File Upload

Also known asBIT-mlflow-2023-6015GHSA-f798-qm4r-23r5PYSEC-2026-420
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Oct 27, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
4.5%probability of exploitation in next 30 days
Lower Risk+0.04%
Lower risk than most CVEs91th percentile — riskier than 91% of all scored CVEsHighest risk
0.00%1.87%3.74%5.60%0.8%4.5%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍mlflow

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

MLflow allowed arbitrary files to be PUT onto the server.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPImlflowall versions2.8.1pip install --upgrade 'mlflow==2.8.1'

Affected Products

1 product · 1 configurations
Application
mlflowlfprojects
< 2.8.1
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for mlflow, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update mlflow to 2.8.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-6015 is resolved across your whole dependency graph.

  3. Workarounds

    Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.

Frequently Asked Questions

MLflow allowed arbitrary files to be PUT onto the server.
O3 Security · Impact-Aware SCA

Is CVE-2023-6015 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2023-6015: mlflow — Fixed in 2.8.1