CVE-2023-5976 is a medium-severity (CVSS 4.6) CWE-284 vulnerability in microweber/microweber. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for microweber/microweber — see the affected versions and patch details below.
Improper Access Control in microweber/microweber
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-5976.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
microweber/microweberReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Improper Access Control in GitHub repository microweber/microweber prior to 2.0.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | microweber/microweber | all versions | 2.0.0composer require microweber/microweber:^2.0.0 |
Affected Products
microwebermicroweberResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for microweber/microweber, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update microweber/microweber to 2.0.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-5976 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2023-5976 in your dependencies?
Find it across Packagist, including transitive dependencies.