NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

CVE-2023-5863 — phpmyfaq

HIGHFix: thorsten/phpmyfaq@97e813d

CVE-2023-5863 is a high-severity (CVSS 7.4) Cross-site Scripting (XSS) vulnerability in thorsten/phpmyfaq. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for thorsten/phpmyfaq — see the affected versions and patch details below.

Cross-site Scripting (XSS) - Reflected in thorsten/phpmyfaq

Also known asGHSA-j4vj-w5rj-8grw
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.

Exploitation and automatability from CISA’s SSVC triage for CVE-2023-5863.

EPSS Exploitation Probability

via FIRST.org ↗
1.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs65th percentile — riskier than 65% of all scored CVEsHighest risk
0.00%2.59%5.18%7.77%6.2%1.1%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘thorsten/phpmyfaq

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Cross-site Scripting (XSS) - Reflected in GitHub repository thorsten/phpmyfaq prior to 3.2.2.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistthorsten/phpmyfaqall versions3.2.2composer require thorsten/phpmyfaq:^3.2.2

Affected Products

1 product · 1 configurations
Application
phpmyfaqphpmyfaq
< 3.2.2
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for thorsten/phpmyfaq, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update thorsten/phpmyfaq to 3.2.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-5863 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

How to detect CVE-2023-5863

A community-maintained Nuclei template exists for this CVE. You can scan for it directly:

nuclei -id cve-2023-5863 -u https://target
Template
phpMyFAQ < 3.2.0 - Cross-site Scripting
Severity
medium
Impact
Unauthenticated attackers can inject malicious JavaScript via reflected XSS in the action parameter, potentially stealing administrator session cookies or performing administrative actions.
Remediation
Update phpMyFAQ to version 3.2.2 or later.

Template by ProjectDiscovery nuclei-templates (ctflearner), MIT licensed. View the full template. Scan only systems you are authorised to test.

Frequently Asked Questions

Cross-site Scripting (XSS) - Reflected in GitHub repository thorsten/phpmyfaq prior to 3.2.2.
O3 Security · Impact-Aware SCA

Is CVE-2023-5863 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2023-5863: phpmyfaq XSS — Fixed in 3.2.2