CVE-2023-5550 is a medium-severity (CVSS 6.5) Code Injection vulnerability in moodle/moodle. A fix is available for moodle/moodle — see the affected versions and patch details below.
Moodle: rce due to lfi risk in some misconfigured shared hosting environments
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-5550.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
moodle/moodle🐘moodle/moodle🐘moodle/moodle🐘moodle/moodle🐘moodle/moodle🐘moodle/moodleReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
In a shared hosting environment that has been misconfigured to allow access to other users' content, a Moodle user who also has direct access to the web server outside of the Moodle webroot could utilise a local file include to achieve remote code execution.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | moodle/moodle | ≥ 4.3.0-beta&&< 4.3.0-rc2 | 4.3.0-rc2composer require moodle/moodle:^4.3.0-rc2 |
| 🐘Packagist | moodle/moodle | ≥ 4.2.0&&< 4.2.3 | 4.2.3composer require moodle/moodle:^4.2.3 |
| 🐘Packagist | moodle/moodle | ≥ 4.1.0&&< 4.1.6 | 4.1.6composer require moodle/moodle:^4.1.6 |
| 🐘Packagist | moodle/moodle | ≥ 4.0.0&&< 4.0.11 | 4.0.11composer require moodle/moodle:^4.0.11 |
| 🐘Packagist | moodle/moodle | ≥ 3.10.0&&< 3.11.17 | 3.11.17composer require moodle/moodle:^3.11.17 |
| 🐘Packagist | moodle/moodle | all versions | 3.9.24composer require moodle/moodle:^3.9.24 |
Affected Products
extra packages for enterprise linuxfedoraprojectfedorafedoraprojectmoodlemoodleDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moodle/moodle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update moodle/moodle to 4.3.0-rc2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-5550 is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
Frequently Asked Questions
Is CVE-2023-5550 in your dependencies?
Find it across Packagist, including transitive dependencies.