NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
LOW severity

CVE-2023-5548 — moodle

LOWFix: moodle/moodle@7679452

CVE-2023-5548 is a low-severity (CVSS 3.3) CWE-349 vulnerability in moodle/moodle. A fix is available for moodle/moodle — see the affected versions and patch details below.

Moodle: cache poisoning risk with endpoint revision numbers

Also known asBIT-moodle-2023-5548GHSA-cwh2-q44x-5w3c
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs25th percentile — riskier than 25% of all scored CVEsHighest risk
0.00%0.27%0.55%0.82%0.3%0.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘moodle/moodle

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Stronger revision number limitations were required on file serving endpoints to improve cache poisoning protection.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmoodle/moodleall versions4.3.0-rc2composer require moodle/moodle:^4.3.0-rc2

Affected Products

3 products · 7 configurations
Application
extra packages for enterprise linuxfedoraproject
1 version
7.0
OS
fedorafedoraproject
1 version
38
Application
moodlemoodle
≥ 4.2.0 && < 4.2.3
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moodle/moodle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update moodle/moodle to 4.3.0-rc2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-5548 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Stronger revision number limitations were required on file serving endpoints to improve cache poisoning protection.
O3 Security · Impact-Aware SCA

Is CVE-2023-5548 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2023-5548: moodle — Fixed in 4.3.0-rc2