NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
LOW severity

CVE-2023-5545 — moodle

LOWFix: moodle/moodle@100ac7c

CVE-2023-5545 is a low-severity (CVSS 3.3) Information Exposure vulnerability in moodle/moodle. A fix is available for moodle/moodle — see the affected versions and patch details below.

Moodle: auto-populated h5p author name causes a potential information leak

Also known asBIT-moodle-2023-5545GHSA-26fg-v32r-h663
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2023-5545.

EPSS Exploitation Probability

via FIRST.org ↗
0.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs48th percentile — riskier than 48% of all scored CVEsHighest risk
0.00%0.36%0.72%1.08%0.3%0.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘moodle/moodle

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

H5P metadata automatically populated the author with the user's username, which could be sensitive information.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmoodle/moodleall versions4.3.0-rc2composer require moodle/moodle:^4.3.0-rc2

Affected Products

3 products · 7 configurations
Application
extra packages for enterprise linuxfedoraproject
1 version
7.0
OS
fedorafedoraproject
1 version
38
Application
moodlemoodle
≥ 4.2.0 && < 4.2.3
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moodle/moodle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update moodle/moodle to 4.3.0-rc2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-5545 is resolved across your whole dependency graph.

  3. Workarounds

    Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.

Frequently Asked Questions

H5P metadata automatically populated the author with the user's username, which could be sensitive information.
O3 Security · Impact-Aware SCA

Is CVE-2023-5545 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2023-5545: moodle — Fixed in 4.3.0-rc2