NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2023-5540 — moodle

MEDIUMFix: moodle/moodle@3400ae6

CVE-2023-5540 is a medium-severity (CVSS 4.7) Code Injection vulnerability in moodle/moodle. A fix is available for moodle/moodle — see the affected versions and patch details below.

Moodle: authenticated remote code execution risk in imscp

Also known asBIT-moodle-2023-5540GHSA-w8x2-w4qr-v3x4
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 1, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2023-5540.

EPSS Exploitation Probability

via FIRST.org ↗
2.3%probability of exploitation in next 30 days
Lower Risk+0.34%
Lower risk than most CVEs83th percentile — riskier than 83% of all scored CVEsHighest risk
1.43%1.88%2.32%2.77%2.0%2.3%May 26Aug 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘moodle/moodle

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

A remote code execution risk was identified in the IMSCP activity. By default this was only available to teachers and managers.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmoodle/moodleall versions4.3.0-rc2composer require moodle/moodle:^4.3.0-rc2

Affected Products

3 products · 7 configurations
Application
extra packages for enterprise linuxfedoraproject
1 version
7.0
OS
fedorafedoraproject
1 version
38
Application
moodlemoodle
≥ 4.2.0 && < 4.2.3
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moodle/moodle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update moodle/moodle to 4.3.0-rc2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-5540 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Frequently Asked Questions

A remote code execution risk was identified in the IMSCP activity. By default this was only available to teachers and managers.
O3 Security · Impact-Aware SCA

Is CVE-2023-5540 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2023-5540: moodle RCE — Fixed in 4.3.0-rc2