CVE-2023-53160 — sequoia-openpgp
LOWCVE-2023-53160 is a low-severity (CVSS 2.9) Out-of-bounds Read vulnerability in sequoia-openpgp. A fix is available for sequoia-openpgp — see the affected versions and patch details below.
sequoia-openpgp vulnerable to out-of-bounds array access leading to panic
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-53160.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
sequoia-openpgp🦀sequoia-openpgp🦀sequoia-openpgpReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects crates.io packages — download data is not available via public APIs for these ecosystems.
Description
Affected versions of the crate have several bugs where attacker-controlled input can result in the use of an out-of-bound array index. Rust detects the use of the out-of-bound index and causes the application to panic. An attacker may be able to use this to cause a denial-of-service. However, it is not possible for an attacker to read from or write to the application's address space.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🦀crates.io | sequoia-openpgp | all versions | 1.1.1cargo update -p sequoia-openpgp --precise 1.1.1 |
| 🦀crates.io | sequoia-openpgp | ≥ 1.2.0&&< 1.8.1 | 1.8.1cargo update -p sequoia-openpgp --precise 1.8.1 |
| 🦀crates.io | sequoia-openpgp | ≥ 1.9.0&&< 1.16.0 | 1.16.0cargo update -p sequoia-openpgp --precise 1.16.0 |
Affected Products
sequoia-openpgpsequoia-pgpDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for sequoia-openpgp, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update sequoia-openpgp to 1.1.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-53160 is resolved across your whole dependency graph.
Workarounds
Constrain what reaches the vulnerable code: limit the size and shape of untrusted input, isolate the affected component in a sandboxed or least-privileged process, and enable the platform's memory-safety mitigations (ASLR, stack protector, hardened allocator) so an out-of-bounds access is more likely to fail closed than to be exploitable.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.Source: Red Hat security advisory for CVE-2023-53160 (CC BY 4.0)
Frequently Asked Questions
Is CVE-2023-53160 in your dependencies?
Find it across crates.io, including transitive dependencies.