CVE-2023-51080 is a high-severity (CVSS 7.5) Out-of-bounds Write vulnerability in cn.hutool:hutool-core. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for cn.hutool:hutool-core — see the affected versions and patch details below.
hutool-core was discovered to contain a stack overflow via NumberUtil.toBigDecimal method
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
cn.hutool:hutool-coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
The NumberUtil.toBigDecimal method in hutool-core v5.8.23 was discovered to contain a stack overflow.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | cn.hutool:hutool-core | ≥ 5.8.22&&< 5.8.25 | 5.8.25cn.hutool:hutool-core:5.8.25 |
Affected Products
hutoolhutoolResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for cn.hutool:hutool-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update cn.hutool:hutool-core to 5.8.25 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-51080 is resolved across your whole dependency graph.
Workarounds
Constrain what reaches the vulnerable code: limit the size and shape of untrusted input, isolate the affected component in a sandboxed or least-privileged process, and enable the platform's memory-safety mitigations (ASLR, stack protector, hardened allocator) so an out-of-bounds access is more likely to fail closed than to be exploitable.
Frequently Asked Questions
Is CVE-2023-51080 in your dependencies?
Find it across Maven, including transitive dependencies.