NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2023-50730 — grackle-core_2.13

HIGHFix: typelevel/grackle@56e244b

CVE-2023-50730 is a high-severity (CVSS 7.5) Uncontrolled Resource Consumption vulnerability in org.typelevel:grackle-core_2.13. A fix is available for org.typelevel:grackle-core_2.13 — see the affected versions and patch details below.

Grackle has StackOverflowError in GraphQL query processing

Also known asGHSA-g56x-7j6w-g8r8
Published
Updated
Affected
12 pkgs
Patched
6 / 12
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs58th percentile — riskier than 58% of all scored CVEsHighest risk
0.02%0.46%0.89%1.33%0.5%0.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

12 pkgs affected
☕org.typelevel:grackle-core_2.13☕org.typelevel:grackle-core_3☕org.typelevel:grackle-core_sjs1_2.13☕org.typelevel:grackle-core_sjs1_3☕org.typelevel:grackle-core_native0.4_2.13☕org.typelevel:grackle-core_native0.4_3☕edu.gemini:gsp-graphql-core_2.13☕edu.gemini:gsp-graphql-core_3+4 more

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Grackle is a GraphQL server written in functional Scala, built on the Typelevel stack. The GraphQL specification requires that GraphQL fragments must not form cycles, either directly or indirectly. Prior to Grackle version 0.18.0, that requirement wasn't checked, and queries with cyclic fragments would have been accepted for type checking and compilation. The attempted compilation of such fragments would result in a JVM StackOverflowError being thrown. Some knowledge of an applications GraphQL schema would be required to construct such a query, however no knowledge of any application-specific performance or other behavioural characteristics would be needed.

Grackle uses the cats-parse library for parsing GraphQL queries. Prior to version 0.18.0, Grackle made use of the cats-parse recursive operator. However, recursive is not currently stack safe. recursive was used in three places in the parser: nested selection sets, nested input values (lists and objects), and nested list type declarations. Consequently, queries with deeply nested selection sets, input values or list types could be constructed which exploited this, causing a JVM StackOverflowException to be thrown during parsing. Because this happens very early in query processing, no specific knowledge of an applications GraphQL schema would be required to construct such a query.

The possibility of small queries resulting in stack overflow is a potential denial of service vulnerability. This potentially affects all applications using Grackle which have untrusted users. Both stack overflow issues have been resolved in the v0.18.0 release of Grackle. As a workaround, users could interpose a sanitizing layer in between untrusted input and Grackle query processing.

Affected Packages

12 total 6 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.typelevel:grackle-core_2.13all versions0.18.0org.typelevel:grackle-core_2.13:0.18.0
☕Mavenorg.typelevel:grackle-core_3all versions0.18.0org.typelevel:grackle-core_3:0.18.0
☕Mavenorg.typelevel:grackle-core_sjs1_2.13all versions0.18.0org.typelevel:grackle-core_sjs1_2.13:0.18.0
☕Mavenorg.typelevel:grackle-core_sjs1_3all versions0.18.0org.typelevel:grackle-core_sjs1_3:0.18.0
☕Mavenorg.typelevel:grackle-core_native0.4_2.13all versions0.18.0org.typelevel:grackle-core_native0.4_2.13:0.18.0
☕Mavenorg.typelevel:grackle-core_native0.4_3all versions0.18.0org.typelevel:grackle-core_native0.4_3:0.18.0

Affected Products

1 product · 1 configurations
Application
grackletypelevel
< 0.18.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.typelevel:grackle-core_2.13, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.typelevel:grackle-core_2.13 to 0.18.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-50730 is resolved across your whole dependency graph.

  3. Workarounds

    Stop feeding it untrusted input: reject or quarantine files and payloads from unverified sources until you can upgrade, restrict accepted formats to the ones you actually need, and run the parsing or decoding step in a least-privileged sandbox or short-lived worker so a crash or corrupted read cannot reach the rest of the process.

Frequently Asked Questions

Grackle is a GraphQL server written in functional Scala, built on the Typelevel stack. The GraphQL specification requires that GraphQL fragments must not form cycles, either directly or indirectly. Prior to Grackle version 0.18.0, that requirement wasn't checked, and queries with cyclic fragments would have been accepted for type checking and compilation. The attempted compilation of such fragments would result in a JVM `StackOverflowError` being thrown. Some knowledge of an applications GraphQL schema would be required to construct such a query, however no knowledge of any application-specifi
O3 Security · Impact-Aware SCA

Is CVE-2023-50730 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2023-50730: grackle-core_2.13 DoS — Fixed in 0.18.0