CVE-2023-50447 is a high-severity (CVSS 8.1) Code Injection vulnerability in pillow. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for pillow — see the affected versions and patch details below.
Arbitrary Code Execution in Pillow
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-50447.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
pillowReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Pillow through 10.1.0 allows PIL.ImageMath.eval Arbitrary Code Execution via the environment parameter, a different vulnerability than CVE-2022-22817 (which was about the expression parameter).
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | pillow | all versions | 10.2.0pip install --upgrade 'pillow==10.2.0' |
Affected Products
debian linuxdebianpillowpythonResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for pillow, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update pillow to 10.2.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-50447 is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
The vulnerability in Pillow's PIL.ImageMath.eval function poses a significant threat due to its potential for arbitrary code execution. Pillow's widespread use in diverse domains makes this flaw particularly impactful, as it could lead to unauthorized access, data breaches, and compromise of entire systems. The…
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.Source: Red Hat security advisory for CVE-2023-50447 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Ansible Automation Platform 2.4 for RHEL 8 | python3x-pillow-0:10.3.0-1.el8ap | RHSA-2024:3781 |
| Red Hat Enterprise Linux 7 | python-pillow-0:2.0.0-25.gitd1c6db8.el7_9 | RHSA-2024:0857 |
| Red Hat Enterprise Linux 8 | python-pillow-0:5.1.1-18.el8_9.1 | RHSA-2024:0893 |
| Red Hat Enterprise Linux 8.2 Advanced Update Support | python-pillow-0:5.1.1-15.el8_2 | RHSA-2024:1059 |
| Red Hat Enterprise Linux 8.4 Advanced Mission Critical Update Support | python-pillow-0:5.1.1-15.el8_4 | RHSA-2024:1060 |
| Red Hat Enterprise Linux 8.6 Extended Update Support | python-pillow-0:5.1.1-19.el8_6 | RHSA-2024:1058 |
| Red Hat Enterprise Linux 8.8 Extended Update Support | python-pillow-0:5.1.1-19.el8_8 | RHSA-2024:0754 |
Frequently Asked Questions
Is CVE-2023-50447 in your dependencies?
Find it across PyPI, including transitive dependencies.