CVE-2023-50290 is a medium-severity (CVSS 6.5) Information Exposure vulnerability in org.apache.solr:solr-core. EPSS puts its 30-day exploitation probability at 68.4% (99th percentile). A fix is available for org.apache.solr:solr-core — see the affected versions and patch details below.
Apache Solr: Host environment variables are published via the Metrics API
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-50290.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.solr:solr-coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache Solr. The Solr Metrics API publishes all unprotected environment variables available to each Apache Solr instance. Users are able to specify which environment variables to hide, however, the default list is designed to work for known secret Java system properties. Environment variables cannot be strictly defined in Solr, like Java system properties can be, and may be set for the entire host, unlike Java system properties which are set per-Java-proccess.
The Solr Metrics API is protected by the "metrics-read" permission. Therefore, Solr Clouds with Authorization setup will only be vulnerable via users with the "metrics-read" permission. This issue affects Apache Solr: from 9.0.0 before 9.3.0.
Users are recommended to upgrade to version 9.3.0 or later, in which environment variables are not published via the Metrics API.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.solr:solr-core | ≥ 9.0.0&&< 9.3.0 | 9.3.0org.apache.solr:solr-core:9.3.0 |
Affected Products
solrapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.solr:solr-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.solr:solr-core to 9.3.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-50290 is resolved across your whole dependency graph.
Workarounds
Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.
How to detect CVE-2023-50290
A community-maintained Nuclei template exists for this CVE. You can scan for it directly:
nuclei -id cve-2023-50290 -u https://target- Template
- Apache Solr - Host Environment Variables Leak via Metrics API
- Severity
- medium
- Impact
- This vulnerability can lead to the exposure of sensitive information, potentially allowing an attacker to gain unauthorized access or perform further attacks.
- Remediation
- Users are recommended to upgrade to version 9.3.0 or later, in which environment variables are not published via the Metrics API.
Template by ProjectDiscovery nuclei-templates (Banana69, DhiyaneshDK), MIT licensed. View the full template. Scan only systems you are authorised to test.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Fuse 7.13.0 | solr | RHSA-2024:3354 |
Frequently Asked Questions
Is CVE-2023-50290 in your dependencies?
Find it across Maven, including transitive dependencies.