NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
HIGH severity

CVE-2023-49568 — go-git

HIGH

CVE-2023-49568 is a high-severity (CVSS 7.5) Improper Input Validation vulnerability in github.com/go-git/go-git/v5. A fix is available for github.com/go-git/go-git/v5 — see the affected versions and patch details below.

Maliciously crafted Git server replies can cause DoS on go-git clients

Also known asGHSA-mw99-9chc-xw7rGO-2024-2466
Published
Updated
Affected
2 pkgs
Patched
1 / 2
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2023-49568.

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs53th percentile — riskier than 53% of all scored CVEsHighest risk
0.00%0.40%0.80%1.20%0.1%0.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐹github.com/go-git/go-git/v5🐹gopkg.in/src-d/go-git.v4

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

Impact

A denial of service (DoS) vulnerability was discovered in go-git versions prior to v5.11. This vulnerability allows an attacker to perform denial of service attacks by providing specially crafted responses from a Git server which triggers resource exhaustion in go-git clients.

Applications using only the in-memory filesystem supported by go-git are not affected by this vulnerability. This is a go-git implementation issue and does not affect the upstream git cli.

Patches

Users running versions of go-git from v4 and above are recommended to upgrade to v5.11 in order to mitigate this vulnerability.

Workarounds

In cases where a bump to the latest version of go-git is not possible, we recommend limiting its use to only trust-worthy Git servers.

Credit

Thanks to Ionut Lalu for responsibly disclosing this vulnerability to us.

References

Affected Packages

2 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/go-git/go-git/v5all versions5.11.0go get github.com/go-git/go-git/v5@v5.11.0
🐹Gogopkg.in/src-d/go-git.v4≥ 4.7.1No fix

Affected Products

1 product · 1 configurations
Application
go-gitgo-git_project
≥ 4.0.0 && < 5.11.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/go-git/go-git/v5, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/go-git/go-git/v5 to 5.11.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-49568 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant

This problem only affects the go implementation and not the original git cli code. Applications using only in-memory filesystems are not affected by this issue. Clients should be limited to connect to only trusted git servers to reduce the risk of compromise.

Workaround published by Red Hat
In cases where a bump to the latest version of go-git is not possible, a recommendation to reduce the exposure of this threat is limiting its use to only trust-worthy Git servers.
Source: Red Hat security advisory for CVE-2023-49568 (CC BY 4.0)
ProductFixed inAdvisory
multicluster-globalhub 1.0 for RHEL 8multicluster-globalhub/multicluster-globalhub-grafana-rhel8:v1.0.2-4RHSA-2024:0989
OPENSHIFT-BUILDS-1.0-RHEL-8openshift-builds/openshift-builds-controller-rhel8:v1.0.1-4RHSA-2024:1557
Openshift Serverless 1 on RHEL 8openshift-serverless-clients-0:1.10.0-6.el8RHSA-2024:0880
Red Hat Advanced Cluster Management for Kubernetes 2.9 for RHEL 8rhacm2/multicluster-operators-subscription-rhel8:v2.9.2-2RHSA-2024:0298
Red Hat Advanced Cluster Security 4.4advanced-cluster-security/rhacs-central-db-rhel8:4.4.0-9RHSA-2024:1570
Red Hat Ceph Storage 7.1ceph-2:18.2.1-194.el8cpRHSA-2024:3925
Red Hat OpenShift Container Platform 4.12openshift4/ose-ansible-operator:v4.12.0-202402081808.p0.g0bd975e.assembly.stream.el8RHSA-2024:0832
Red Hat OpenShift Container Platform 4.12openshift4/ose-operator-lifecycle-manager:v4.12.0-202402111607.p0.g9dd28b4.assembly.stream.el8RHSA-2024:0833

Frequently Asked Questions

### Impact A denial of service (DoS) vulnerability was discovered in go-git versions prior to `v5.11`. This vulnerability allows an attacker to perform denial of service attacks by providing specially crafted responses from a Git server which triggers resource exhaustion in `go-git` clients. Applications using only the in-memory filesystem supported by `go-git` are not affected by this vulnerability. This is a `go-git` implementation issue and does not affect the upstream `git` cli. ### Patches Users running versions of `go-git` from `v4` and above are recommended to upgrade to `v5.11` in o
O3 Security · Impact-Aware SCA

Is CVE-2023-49568 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2023-49568: go-git DoS — Fixed in 5.11.0