CVE-2023-49438 is a medium-severity (CVSS 6.1) Open Redirect vulnerability in flask-security-too. 3 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for flask-security-too — see the affected versions and patch details below.
Open redirect vulnerability in Flask-Security-Too
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
flask-security-tooReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
An open redirect vulnerability in the python package Flask-Security-Too <=5.3.2 allows attackers to redirect unsuspecting users to malicious sites via a crafted URL by abusing the ?next parameter on the /login and /register routes.
Flask-Security-Too contains logic to validate that the URL specified within the next parameter is either relative or has the same network location as the requesting URL in an attempt to prevent open redirections. Previously known examples that bypassed the validation logic such as https://example/login?next=\\\\\\github.com were patched in version 4.1.0
However, examples such as https://example/login?next=/\\github.com and https://example/login?next=\\/github.com were discovered due to how web browsers normalize slashes in URLs, which makes the package vulnerable through version <=5.3.2
Additionally, with Werkzeug >=2.1.0 the autocorrect_location_header configuration was changed to False - which means that location headers in redirects are relative by default. Thus, this issue may impact applications that were previously not impacted, if they are using Werkzeug >=2.1.0 as the WSGI layer.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | flask-security-too | all versions | 5.3.3pip install --upgrade 'flask-security-too==5.3.3' |
Affected Products
flask-security-tooflask-security-too_projectResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for flask-security-too, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update flask-security-too to 5.3.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-49438 is resolved across your whole dependency graph.
Workarounds
Stop reflecting attacker-controlled destinations: resolve every redirect target against an allowlist of paths or hosts you own, prefer a server-side key over a full URL in the request, and reject absolute URLs entirely where the flow only ever needs a relative one.
How to detect CVE-2023-49438
A community-maintained Nuclei template exists for this CVE. You can scan for it directly:
nuclei -id cve-2023-49438 -u https://target- Template
- Python Flask-Security-Too <=5.3.2 - Open Redirect
- Severity
- medium
- Impact
- Allows attackers to redirect users to arbitrary sites, potentially leading to phishing, data theft, or user session hijacking.
- Remediation
- Upgrade Flask-Security-Too to version 5.3.3 or later to mitigate the open redirect vulnerability.
Template by ProjectDiscovery nuclei-templates (ritikchaddha), MIT licensed. View the full template. Scan only systems you are authorised to test.
Frequently Asked Questions
Is CVE-2023-49438 in your dependencies?
Find it across PyPI, including transitive dependencies.