CVE-2023-49097 — zitadel
HIGHCVE-2023-49097 is a high-severity (CVSS 8.1) CWE-640 vulnerability in github.com/zitadel/zitadel. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for github.com/zitadel/zitadel — see the affected versions and patch details below.
ZITADEL vulnerable account takeover via malicious host header injection
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-49097.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/zitadel/zitadel🐹github.com/zitadel/zitadel🐹github.com/zitadel/zitadelReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Impact
ZITADEL uses the notification triggering requests Forwarded or X-Forwarded-Host header to build the button link sent in emails for confirming a password reset with the emailed code. If this header is overwritten and a user clicks the link to a malicious site in the email, the secret code can be retrieved and used to reset the users password and take over his account.
Accounts with MFA or Passwordless enabled can not be taken over by this attack.
Patches
The patched ZITADEL versions verify, that the auth requests instance is retrieved by the requests original domain (from the Forwarded or X-Forwarded-Host headers if available). If the instance can't be found using the original host or the auth request can't be found within that instance, ZITADEL throws an error.
2.x versions are fixed on >= 2.41.6 2.40.x versions are fixed on >= 2.40.10 2.39.x versions are fixed on >= 2.39.9
The vulnerablility was introduced with 2.39.0.
Workarounds
A ZITADEL fronting proxy can be configured to delete all Forwarded and X-Forwarded-Host header values before sending requests to ZITADEL self-hosted environments.
References
None
Questions
If you have any questions or comments about this advisory, please email us at [email protected]
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/zitadel/zitadel | ≥ 2.39.0&&< 2.39.9 | 2.39.9go get github.com/zitadel/zitadel@v2.39.9 |
| 🐹Go | github.com/zitadel/zitadel | ≥ 2.40.0&&< 2.40.10 | 2.40.10go get github.com/zitadel/zitadel@v2.40.10 |
| 🐹Go | github.com/zitadel/zitadel | ≥ 2.41.0&&< 2.41.6 | 2.41.6go get github.com/zitadel/zitadel@v2.41.6 |
Affected Products
zitadelzitadelResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/zitadel/zitadel, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/zitadel/zitadel to 2.39.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-49097 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2023-49097 in your dependencies?
Find it across Go, including transitive dependencies.