NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
MEDIUM severity

CVE-2023-48713 — serving

MEDIUMFix: knative/serving@012ee25

CVE-2023-48713 is a medium-severity (CVSS 6.5) Uncontrolled Resource Consumption vulnerability in knative.dev/serving. A fix is available for knative.dev/serving — see the affected versions and patch details below.

Knative Serving vulnerable to attacker-controlled pod causing denial of service of autoscaler

Also known asGHSA-qmvj-4qr9-v547GO-2023-2355
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2023-48713.

EPSS Exploitation Probability

via FIRST.org ↗
0.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs59th percentile — riskier than 59% of all scored CVEsHighest risk
0.00%0.46%0.91%1.37%0.1%0.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐹knative.dev/serving

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

Summary

A vulnerability was fond in Knative Serving that could allow an attacker to crash the Knative Serving autoscaler resulting in a denial of service. The attacker would need to have compromised one pod in the Knative Serving deployment, and with that position they could launch the attack against the autoscaler. When the autoscaler scrapes the metrics of pods, it sends a request to the /metrics endpoint of each pod and reads the response. The attacker would need to detect the request from the autoscaler to the /metrics endpoint of the pod they had compromised and send a malicious response back to the autoscaler. At this point, the autoscaler would crash. The root cause of the vulnerability was a memory exhaustion issue in the autoscaler that the attacker could trigger with the malicious reponse.

The vulnerability would allow a privilege escalation by the attacker from controlling one point to having negative impact on the entire Knative Serving deployment.

Impact

All users are vulnerable to this; Users that have not had any of their pods compromised are not at risk of this vulnerability.

Mitigation

The vulnerability has been patched in v1.10.5, v1.11.3 and v1.12.0

Credits

The vulnerability was reported by Ada Logics during an ongoing security audit of Knative involving Ada Logics, the Knative maintainers, OSTIF and CNCF.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐹Goknative.dev/servingall versions0.39.0go get knative.dev/serving@v0.39.0

Affected Products

1 product · 2 configurations
Application
servingknative
≥ 1.11.0 && < 1.11.3
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for knative.dev/serving, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update knative.dev/serving to 0.39.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-48713 is resolved across your whole dependency graph.

  3. Workarounds

    Close the privilege gap rather than the entry point: audit which accounts, roles and service identities can reach the affected operation, drop the component to the least privilege it actually needs, and review file and directory permissions created by earlier installs — a default left in place is what makes this reachable.

Frequently Asked Questions

### Summary A vulnerability was fond in Knative Serving that could allow an attacker to crash the Knative Serving autoscaler resulting in a denial of service. The attacker would need to have compromised one pod in the Knative Serving deployment, and with that position they could launch the attack against the autoscaler. When the autoscaler scrapes the metrics of pods, it sends a request to the `/metrics` endpoint of each pod and reads the response. The attacker would need to detect the request from the autoscaler to the `/metrics` endpoint of the pod they had compromised and send a malicious
O3 Security · Impact-Aware SCA

Is CVE-2023-48713 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2023-48713: serving PrivEsc — Fixed in 0.39.0