CVE-2023-48705 is a high-severity (CVSS 7.1) Cross-site Scripting (XSS) vulnerability in nautobot. A fix is available for nautobot — see the affected versions and patch details below.
nautobot has XSS potential in custom links, job buttons, and computed fields
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
nautobot🐍nautobotReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Impact
All users of Nautobot versions earlier than 1.6.6 or 2.0.5 are potentially affected.
Due to incorrect usage of Django's mark_safe() API when rendering certain types of user-authored content, including:
- custom links
- job buttons
- computed fields
it is possible that users with permission to create or edit these types of content could craft a malicious payload (such as JavaScript code) that would be executed when rendering pages containing this content.
Patches
Has the problem been patched? What versions should users upgrade to?
We have fixed the incorrect uses of mark_safe() (generally by replacing them with appropriate use of format_html() instead) to prevent such malicious data from being executed.
Users on Nautobot 1.6.x LTM should upgrade to v1.6.6 and users on Nautobot 2.0.x should upgrade to v2.0.5.
Workarounds
Is there a way for users to fix or remediate the vulnerability without upgrading?
Appropriate object permissions can and should be applied to restrict which users are permitted to create or edit the aforementioned types of user-authored content. Other than that, there is no direct fix available.
References
Are there any links users can visit to find out more?
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | nautobot | all versions | 1.6.6pip install --upgrade 'nautobot==1.6.6' |
| 🐍PyPI | nautobot | ≥ 2.0.0&&< 2.0.5 | 2.0.5pip install --upgrade 'nautobot==2.0.5' |
Affected Products
nautobotnetworktocodeDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for nautobot, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update nautobot to 1.6.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-48705 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2023-48705 in your dependencies?
Find it across PyPI, including transitive dependencies.