CVE-2023-48241 is a high-severity (CVSS 7.5) CWE-285 vulnerability in org.xwiki.platform:xwiki-platform-search-solr-query. EPSS puts its 30-day exploitation probability at 72.8% (99th percentile). A fix is available for org.xwiki.platform:xwiki-platform-search-solr-query — see the affected versions and patch details below.
XWiki exposed whole content of all documents of all wikis to anybody with view right on Solr suggest service
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.xwiki.platform:xwiki-platform-search-solr-query☕org.xwiki.platform:xwiki-platform-search-solr-queryReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Impact
The Solr-based search suggestion provider that also duplicates as generic JavaScript API for search results in XWiki exposes the content of all documents of all wikis to anybody who has access to it, by default it is public. This exposes all information stored in the wiki (but not some protected information like password hashes). While there is a right check normally, the right check can be circumvented by explicitly requesting fields from Solr that don't include the data for the right check. This can be reproduced by opening <xwiki-server>/xwiki/bin/get/XWiki/SuggestSolrService?outputSyntax=plain&media=json&nb=1000&query=q%3D*%3A*%0Aq.op%3DAND%0Afq%3Dtype%3ADOCUMENT%0Afl%3Dtitle_%2C+reference%2C+links%2C+doccontentraw_%2C+objcontent__&input=+ where <xwiki-server> is the URL of the XWiki installation. If this displays any results, the wiki is vulnerable.
Patches
This has been fixed in XWiki 15.6RC1, 15.5.1 and 14.10.15 by not listing documents whose rights cannot be checked.
Workarounds
We're not aware of a workaround apart from upgrading to a fixed version.
References
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.xwiki.platform:xwiki-platform-search-solr-query | ≥ 6.3-milestone-2&&< 14.10.15 | 14.10.15org.xwiki.platform:xwiki-platform-search-solr-query:14.10.15 |
| ☕Maven | org.xwiki.platform:xwiki-platform-search-solr-query | ≥ 15.0-rc-1&&< 15.5.1 | 15.5.1org.xwiki.platform:xwiki-platform-search-solr-query:15.5.1 |
Affected Products
xwikixwikiDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.xwiki.platform:xwiki-platform-search-solr-query, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.xwiki.platform:xwiki-platform-search-solr-query to 14.10.15 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-48241 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
How to detect CVE-2023-48241
A community-maintained Nuclei template exists for this CVE. You can scan for it directly:
nuclei -id cve-2023-48241 -u https://target- Template
- XWiki < 4.10.15 - Information Disclosure
- Severity
- high
- Impact
- Successful exploitation could lead to disclosure of content of all documents of all wikis.
Template by ProjectDiscovery nuclei-templates (ritikchaddha), MIT licensed. View the full template. Scan only systems you are authorised to test.
Frequently Asked Questions
Is CVE-2023-48241 in your dependencies?
Find it across Maven, including transitive dependencies.