NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
HIGH severity

CVE-2023-47105 — chaosblade

HIGHFix: chaosblade-io/chaosblade@6bc73c3

CVE-2023-47105 is a high-severity (CVSS 8.6) OS Command Injection vulnerability in github.com/chaosblade-io/chaosblade. A fix is available for github.com/chaosblade-io/chaosblade — see the affected versions and patch details below.

Chaosblade vulnerable to OS command execution

Also known asGHSA-723h-x37g-f8qmGO-2024-3133
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 1, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
  • A successful exploit gives an attacker total control of the affected component, not partial access.

Exploitation and automatability from CISA’s SSVC triage for CVE-2023-47105.

EPSS Exploitation Probability

via FIRST.org ↗
1.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs77th percentile — riskier than 77% of all scored CVEsHighest risk
0.00%11.3%22.6%34.0%26.5%1.7%May 26Aug 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐹github.com/chaosblade-io/chaosblade

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

exec.CommandContext in Chaosblade 0.3 through 1.7.3, when server mode is used, allows OS command execution via the cmd parameter without authentication.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/chaosblade-io/chaosblade≥ 0.0.3&&< 1.7.41.7.4go get github.com/chaosblade-io/chaosblade@v1.7.4

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/chaosblade-io/chaosblade, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/chaosblade-io/chaosblade to 1.7.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-47105 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

How to detect CVE-2023-47105

A community-maintained Nuclei template exists for this CVE. You can scan for it directly:

nuclei -id cve-2023-47105 -u https://target
Template
Chaosblade < 1.7.4 - Remote Code Execution
Severity
high
Impact
This vulnerability allows unauthenticated attackers to remotely invoke the HTTP service and execute arbitrary commands on any Chaosblade instance with server mode enabled. This could lead to unauthorized access and control over the host system running Chaosblade.
Remediation
Fixed in 1.7.4

Template by ProjectDiscovery nuclei-templates (s4e-io), MIT licensed. View the full template. Scan only systems you are authorised to test.

Frequently Asked Questions

exec.CommandContext in Chaosblade 0.3 through 1.7.3, when server mode is used, allows OS command execution via the cmd parameter without authentication.
O3 Security · Impact-Aware SCA

Is CVE-2023-47105 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2023-47105: chaosblade — Fixed in 1.7.4