CVE-2023-46302 is a critical-severity (CVSS 9.8) Deserialization of Untrusted Data vulnerability in apache-submarine. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for apache-submarine — see the affected versions and patch details below.
Apache Submarine: Fix CVE-2022-1471 SnakeYaml unsafe deserialization
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
apache-submarineReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Apache Software Foundation Apache Submarine has a bug when serializing against yaml. The bug is caused by snakeyaml https://nvd.nist.gov/vuln/detail/CVE-2022-1471 .
Apache Submarine uses JAXRS to define REST endpoints. In order to
handle YAML requests (using application/yaml content-type), it defines
a YamlEntityProvider entity provider that will process all incoming
YAML requests. In order to unmarshal the request, the readFrom method
is invoked, passing the entityStream containing the user-supplied data in submarine-server/server-core/src/main/java/org/apache/submarine/server/utils/YamlUtils.java.
We have now fixed this issue in the new version by replacing to jackson-dataformat-yaml.
This issue affects Apache Submarine: from 0.7.0 before 0.8.0. Users are recommended to upgrade to version 0.8.0, which fixes this issue.
If using the version smaller than 0.8.0 and not want to upgrade, you can try cherry-pick PR https://github.com/apache/submarine/pull/1054 and rebuild the submart-server image to fix this.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | apache-submarine | ≥ 0.7.0&&< 0.8.0 | 0.8.0pip install --upgrade 'apache-submarine==0.8.0' |
Affected Products
submarineapacheResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for apache-submarine, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update apache-submarine to 0.8.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-46302 is resolved across your whole dependency graph.
Workarounds
Do not deserialise data from untrusted sources: where the format allows it, restrict deserialisation to an explicit allowlist of expected types, and prefer a data-only format (JSON, Protobuf) over one that can reconstruct arbitrary objects until you can upgrade.
Frequently Asked Questions
Is CVE-2023-46302 in your dependencies?
Find it across PyPI, including transitive dependencies.