CVE-2023-45809 is a low-severity (CVSS 2.7) Information Exposure vulnerability in wagtail. A fix is available for wagtail — see the affected versions and patch details below.
Disclosure of user names via admin bulk action views in wagtail
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
wagtail🐍wagtail🐍wagtailReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Impact
A user with a limited-permission editor account for the Wagtail admin can make a direct URL request to the admin view that handles bulk actions on user accounts. While authentication rules prevent the user from making any changes, the error message discloses the display names of user accounts, and by modifying URL parameters, the user can retrieve the display name for any user. The vulnerability is not exploitable by an ordinary site visitor without access to the Wagtail admin.
Patches
Patched versions have been released as Wagtail 4.1.9 (LTS), 5.0.5 and 5.1.3. The fix is also included in Release Candidate 1 of the forthcoming Wagtail 5.2 release.
Workarounds
None.
Acknowledgements
Many thanks to @quyenheu for reporting this issue.
For more information
If you have any questions or comments about this advisory:
- Visit Wagtail's support channels
- Email us at [email protected] (view our security policy for more information).
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | wagtail | all versions | 4.1.9pip install --upgrade 'wagtail==4.1.9' |
| 🐍PyPI | wagtail | ≥ 4.2.0&&< 5.0.5 | 5.0.5pip install --upgrade 'wagtail==5.0.5' |
| 🐍PyPI | wagtail | ≥ 5.1.0&&< 5.1.3 | 5.1.3pip install --upgrade 'wagtail==5.1.3' |
Affected Products
wagtailtorchboxDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for wagtail, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update wagtail to 4.1.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-45809 is resolved across your whole dependency graph.
Workarounds
Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.
Frequently Asked Questions
Is CVE-2023-45809 in your dependencies?
Find it across PyPI, including transitive dependencies.