NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
CRITICAL severity

CVE-2023-44794 — sa-token-core

CRITICALFix: dromara/Sa-Token@954efeb

CVE-2023-44794 is a critical-severity (CVSS 9.8) CWE-284 vulnerability in cn.dev33:sa-token-core. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for cn.dev33:sa-token-core — see the affected versions and patch details below.

SaToken privilege escalation vulnerability

Also known asGHSA-54f6-9mx9-86f7
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • A successful exploit gives an attacker total control of the affected component, not partial access.

Exploitation and automatability from CISA’s SSVC triage for CVE-2023-44794.

EPSS Exploitation Probability

via FIRST.org ↗
1.3%probability of exploitation in next 30 days
Lower Risk+0.37%
Lower risk than most CVEs71th percentile — riskier than 71% of all scored CVEsHighest risk
0.46%1.13%1.80%2.46%2.0%1.3%May 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕cn.dev33:sa-token-core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

An issue in Dromara SaToken version 1.36.0 and before allows a remote attacker to escalate privileges via a crafted payload to the URL.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavencn.dev33:sa-token-coreall versions1.37.0cn.dev33:sa-token-core:1.37.0

Affected Products

1 product · 1 configurations
Application
sa-tokendromara
< 1.37.0
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for cn.dev33:sa-token-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update cn.dev33:sa-token-core to 1.37.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-44794 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

An issue in Dromara SaToken version 1.36.0 and before allows a remote attacker to escalate privileges via a crafted payload to the URL.
O3 Security · Impact-Aware SCA

Is CVE-2023-44794 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2023-44794: sa-token-core — Fixed in 1.37.0